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All brand names and product names are trademarks, registered trademarks or trade names of their respective holders.

General

Every effort has been made to ensure accuracy, however in some cases changes in the products or availability could occur which may not be reflected in this
document. Christie reserves the right to make changes to specifications at any time without notice. Performance specifications are typical, but may vary
depending on conditions beyond Christie's control such as maintenance of the product in proper working conditions. Performance specifications are based on
information available at the time of printing. Christie makes no warranty of any kind with regard to this material, including, but not limited to, implied
warranties of fitness for a particular purpose. Christie will not be liable for errors contained herein or for incidental or consequential damages in connection
with the performance or use of this material. Canadian manufacturing facility is ISO 9001 and 14001 certified.

SOFTWARE LICENSING AGREEMENT
Agreement

a. This Software License Agreement (the “Agreement”) is a legal agreement between the end user, either an individual or business entity, (“Licensee”) and
Christie Digital Systems USA, Inc. (“Christie”) for the software known commercially as Christie® Spyder that accompanies this Agreement and/or is
installed in the server that Licensee has purchased along with related software components, which may include associated media, printed materials and
online or electronic documentation (all such software and materials are referred to herein, collectively, as “Software”). If Licensee does not accept the
terms of this Agreement, Licensee will return the Software to Christie in accordance with Christie's standard return policy in place from time to time. BY
DOWNLOADING, INSTALLING, ACTIVATING OR USING THE SOFTWARE, THE LICENSEE IS AGREEING TO BE BOUND BY THE TERMS OF THIS
AGREEMENT.

b. The Software contains third party software programs which require notices and/or additional terms and conditions. Such required third party notices
and/or additional terms and conditions are located in the Spyder application (Help > About). By accepting this Agreement and using the Software, you
are also accepting any such additional terms and conditions applicable to the third party software programs. To the extent any license for third party
software programs requires an offer to provide source code for those third party software programs, this Agreement constitutes such an offer. You may
request more information or a copy of such source code by contacting Christie at open.source@christiedigital.com. In conjunction with such request,
provide the Christie Product Number, the Software version and the Product Serial Number (if applicable). If applicable, a nominal cost to cover shipping
and media charges will be charged.

License and Restrictions

a. Ownership of Software: Christie retains title and ownership of all rights, including copyright and all other intellectual property rights, in and to the
Software and all copies thereof, regardless of form or media. This license is not a sale of any rights in or to the Software or any copy thereof. Licensee
acquires no right whatsoever to the Software except the right to use the Software in accordance with the terms of this License.

b. Grant of License: Christie grants to Licensee a single license providing a nonexclusive and non-transferable right to use, for personal or internal
business purposes, the executable version of the Software, as long as Licensee complies with the terms and conditions of this License. Christie reserves
all rights not expressly granted to Licensee.

c. Copy Restrictions: Where the Software is provided for download onto a personal computer or similar device, Licensee may make as many copies of the
Software as is reasonably required for Licensee's own use with the Device. Licensee may also make a backup copy of the Software which may be used
only for reinstallation of the Software. Where the software is pre-installed on a server, Licensee may keep one copy of the Software solely for backup or
archival purposes. Unauthorized copying or distribution of the Software is expressly prohibited unless agreed to in writing by Christie. Licensee must
reproduce and include the copyright notice on any backup copy of the Software. Licensee may not remove or alter any proprietary rights or copyright
notice or identification which indicates the ownership of the Software.

d. Use Restrictions: Licensee will not (a) modify, adapt, decompile, disassemble, reverse engineer, or otherwise attempt to derive the source code for the
Software, or create derivative works based on the Software; (b) assign this Agreement or redistribute, encumber, sell, transfer, lease, or grant a
sublicense of the Software or the license granted herein or otherwise transfer rights to the Software to any person or entity except as and when
expressly permitted by this Agreement; (c) directly or indirectly, export or transmit the Software, either alone or bundled with other software, to any
country to which such export or transmission is restricted by any applicable laws without the appropriate prior written consent of the applicable
government entity or department; and (d) publish or otherwise disclose the Software for others to copy. Licensee will make reasonable efforts to prevent
any unauthorized use of the Software by third parties and will advise Licensee's employees of the restrictions upon use restrictions herein.

e. Upgrades and Updates: While Christie is not required to do so, Christie may provide Licensee with upgrades or updates to the Software, including but
not limited to files that are delivered to Licensee via online transmission or otherwise to “patch” or otherwise modify or enhance the software program.
This Agreement covers any upgrades or updates to the Software that Licensee may obtain from Christie or one of its authorized vendors, unless the
upgrade or update comes with its own license agreement. If Licensee decides not to download or install an upgrade or update provided by Christie,
Licensee understands that this could put the Software at risk to serious security threats or cause the Software to be come unstable. Christie may, at its
option, cause an upgrade or update to apply automatically.

Maintenance and Support

a. Christie may, in its sole discretion and without any obligation, provide maintenance and support services related to the Software (“Support Services”).
Support Services are governed by Christie’s policies and programs described in materials available from Christie. Any supplemental software code
provided to Licensee as part of the Support Services will be considered part of the Software and subject to the terms and conditions of this Agreement.

Warranty and Limitation of Liability

a. No Warranties: The Software is provided “as is” and Christie makes no warranty of any kind with regard to the Software. Christie will not be liable for
errors contained in the Software or in connection with the performance or use of the Software. Christie does not warrant that the Software is free from
any defects or that it will operate uninterrupted. Christie warrants that the media on which the Software is distributed will be free from defects in
materials and workmanship under normal use for a period of ninety (90) days from the date of delivery. Christie will replace any defective media
returned to Christie within the ninety (90) day period. The foregoing is Licensee’s sole and exclusive remedy for breach of the warranty given pursuant
to this Section. Christie does not make any other warranties, either express or implied, including, but not limited to, implied warranties of
merchantability, fitness for a particular purpose, title and non-infringement with regard to the Software.



b. Limitations of Liability: IN NO EVENT WILL CHRISTIE BE LIABLE TO ANY PARTY FOR DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL
DAMAGES, INCLUDING LOST PROFITS, LOST REVENUES AND LOST DATA ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS DOCUMENTATION,
EVEN IF CHRISTIE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

CHRISTIE SPECIFICALLY DISCLAIMS ANY WARRANTIES OR CONDITIONS, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OR
CONDITIONS OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE SOFTWARE AND ACCOMPANYING DOCUMENTATION, IF ANY,
PROVIDED HEREUNDER IS PROVIDED “AS IS”. CHRISTIE HAS NO OBLIGATION TO PROVIDE MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR
MODIFICATIONS.

CHRISTIE FURTHER DISCLAIMS ANY AND ALL REPRESENTATIONS RELATING TO THIRD PARTY SOFTWARE WHICH IS EMBEDDED IN THE SOFTWARE.
Some jurisdictions do not allow exclusions or limitations of certain conditions or warranties. Only those exclusions or limitations that are lawful in
Licensee’s jurisdiction will apply to Licensee and, in such instances, Christie’s liability will be limited only to the maximum extent permitted by law.

Termination

a. Christie may terminate this Agreement at any time and for any reason. Christie may also terminate this Agreement if the Licensee breaches or is in
default of any obligation of Licensee under this Agreement. Upon termination of this Agreement, the Licensee will immediately (i) cease using the
Software and (ii) uninstall the Software from any personal computers, servers or other devices (to the extent it is installed thereon). The Licensee’s
obligation under this provision will survive the termination of this Agreement.

General

a. Notices: Unless otherwise set forth in this Agreement, all notices, or other communications hereunder will be deemed to have been duly given when
made in writing and delivered in person, by courier or deposited in the mail, postage prepaid, and registered mail, return receipt requested, and
addressed to Licensee at the billing address supplied to Christie by Licensee, and addressed to Christie at Christie Digital Systems USA, Inc., c/o Christie
Digital Systems Canada, Inc. at 809 Wellington Street North, Kitchener, Ontario, Canada N2G 4Y7, with a copy (which will not constitute notice) to
Christie’s Legal Department at the same address.

b. Severability and Waiver: Any provision of this Agreement which is held by any court to be unenforceable or invalid will be deemed severed from this
Agreement, without affecting any other provision of this Agreement. No waiver by Christie of any particular default or omission committed by Licensee
will affect or impair the right of Christie in respect of any subsequent default or omission of the same or a different kind. No delay or failure by Christie
to exercise any rights in connection with any default or omission committed by Licensee will affect or impair Christie’s rights in respect of that particular
default or omission or any subsequent default or omission of the same or different kind. In any event, time will continue to be of the essence without the
necessity of specific reinstatement.

c. Governing Law: This Agreement is governed by the laws of the State of California, without regard to its conflict of law principles. Any suit or action
arising out of or in connection with this Agreement will be brought in the federal or state courts located in Orange County, State of California. Each of
Licensor and Licensee hereby irrevocably submit to the jurisdiction of such courts for the purpose of such suit or action and expressly and irrevocably
waive, to the fullest extent permitted by law, any objection it may now or hereafter have to the venue of any such suit or action in any such court and
any such claim that any suit or action has been brought in an inconvenient forum.
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Product overview

Spyder is a versatile video processing system that blends, windows, and scales a wide array of video
signals.
The Spyder architecture allows multiple displays to be combined to generate a resolution exceeding
what a single display can handle. Use Spyder to drive multiple displays to achieve greater brightness,
image quality, and resolution than previously possible.
Spyder systems are generally composed of the following base components:

• Spyder—The hardware-based video processor core of the system. Adding additional Spyder
boxes expands the system and allows more video inputs and windows to be managed.

• Spyder Studio—Used to configure the Spyder system and provides online and offline editing
capabilities for creating configurations.
Spyder Studio hosts a virtual version of the Spyder server allowing users to work within the
software as though connected to the system. It provides synchronization options for the user
to take a copy of the system data offline, or to push their offline work to the server hardware.

• External control systems—Use external control protocols to develop customized control
systems and user interfaces. These control systems are generally found in installations where
Spyder is only one of several disparate systems combined to form a larger system. Typical
applications include systems such as Montage II, AMX, or Crestron.

Understanding the visual components
Learn about the relationship between the components of the visual image (VI).

• Visual image (VI)—Internally, Spyder generates a high resolution display, also referred to as
a video canvas. This canvas within Spyder is referred to as the visual image or VI. The VI is
segmented into one or more partitions, known as pixelspaces, which define overall screen sizes
to be output by Spyder.
The VI within a single Spyder has a fixed maximum number of pixels that can be allocated into
individual pixelspaces. The number of available pixels varies according to several factors;
however these are general pixel counts based on processing bit-depth:

• 8 bit—79,626,240 pixels

• 12 bit—53,084,160 pixels

The physical input and output module count in Spyder has no effect on the internal VI size.

• Pixelspace—A pixelspace is a clipping rectangle, used to segment a section of the Spyder VI
for the purpose of defining a screen area.

• Background—Spyder provides two background layers that can contain user-defined still
images loaded into individual pixelspaces. Backgrounds are displayed behind all Spyder layers.

• Keyframe—Visual attributes applied to a layer such as size, position, borders, shadows, or
clone modes are known as keyframe attributes.
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• Layer—A single input displayed on the Spyder visual image, displaying either a live video input
or still image. Each layer is generated by one of the Spyder input modules, and therefore a 1-
to-1 relationship exists between the number of layers in a Spyder system and the number of
physical input cards contained within that system. Layers are also referred to interchangeably
as a window.

• Priority—As it applies to Spyder layers, priority refers to the natural Z-order of multiple layers
stacked on top of each other. Spyder is designed with a physically fixed priority; layer one is
always shown below layer two, layer two is always shown below layer three, and so on.

• Source—A device providing a video input to the Spyder system, such as a computer or media
player. Each source is defined by the user and contains an input configuration, a user definable
name, and either a router input or hard patched layer.

Related documentation
Additional information on Spyder is available in the following documents:

• Christie Spyder X80 Installation and Setup Guide (P/N: 020-102024-XX)

• Christie Spyder Serial Commands Technical Reference (P/N: 020-102207-XX)

Product overview

Spyder Studio User Guide 8
020-102579-01 Rev. 1 (07-2017)
Copyright © 2017 Christie Digital Systems USA Inc. All rights reserved.



Configuring Spyder
Studio

Use the Spyder Studio software to connect to a Spyder, configure the canvas size and pixelspace, and
design the configuration.

Installing the Spyder Studio software
Install the Spyder Studio software on a computer with a resolution of 1920 x 1080 or greater.

Supported operating systems:

• Windows 7 SP1 or newer

Do not use MAC or PC emulators such as VMWare and Microsoft Virtual PC to run Spyder Studio.
Hardware requirements:

• 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor

• 1 GB RAM (32-bit) or 2 GB RAM (64-bit)

• 16 GB available hard disk space (32-bit) or 20 GB (64-bit)

Christie recommends closing all programs before installing the Spyder Studio software.

1. Download Spyder Studio from the Christie website (www.christiedigital.com).

2. Double-click Spyder Studio <version> Setup.exe.

3. Install any prerequisite programs and follow the Spyder Studio installation wizard.
Although the application does not require that it be installed on any particular disk drive, the
data path for the application has been hard coded to C:\SPYDER. All users must have full
control (read and write access) to the installation directory and to C:\SPYDER.

Configuring the network connection
To ensure network performance and consistent communication between Spyder and Spyder Studio
clients, configure the network connection with these recommendations.

• Spyder communicates to its clients over broadcast traffic. This traffic can be intensive to an
already active network. Christie recommends that Spyder and all Spyder Studio clients be
installed on a closed network. Place any unnecessary devices that also generate large amounts
of network traffic on a separate network.

• Christie does not recommend using complex routers and managed switching equipment in the
network as it may cause communication interruptions if they are not configured properly,
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resulting in loss of communication with Spyder. If the connection between Spyder and its
client(s) are interrupted, the communication socket can to break. This causes a temporary loss
of communication until the socket is restored with restarting the client application.

• On computers running Spyder Studio, avoid configuring a network card with multiple IP
addresses and enabling secondary wired/wireless Ethernet connections.

Network cards on client computers must be configured with an IP address in a specific range.

1. Change the Internet Protocol (TCP/IP) properties to have the computer running Spyder Studio
on the same subnet as the Spyder hardware.

2. If Spyder Studio is open, for the settings to be applied, restart the software.

Connecting Spyder Studio to the Spyder
hardware
The computer running Spyder Studio must be connected to the Spyder before a configuration can be
displayed and live changes can be made.

1. Open Spyder Studio.

2. Select Server > Connection Manager.
The server connection manager displays all individual Spyder frames or primary frames
available on the network. Spyder frames configured as expansion frames do not appear in the
Server Connection dialog.

3. In the Current Connection area, select the Spyder from the list, and click Connect.
The Spyder Studio version on the client computer must have the same the firmware version of
the Spyder frame before a connection is allowed. If the software versions do not match, the
Connect button text changes to Update Now and the firmware must be updated.

Related information

Upgrading the firmware on the Spyder (on page 38)

Disconnecting Spyder Studio from a Spyder
To work offline, disconnect Spyder Studio from the hardware.

1. Select Server > Connection Manager
The server connection manager displays all individual Spyder frames or primary frames
available on the network. Spyder frames configured as expansion frames do not appear in the
server connection dialog.

2. Select the device from the list, and click Disconnect.

Adding a router
To have access to more sources than can connect directly to Spyder, add a router to the configuration.

1. Select Tools > Routers > Add New Router.
Alternatively, select a source and in the Router area of the properties, click Add.

2. Type a name for the router.
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3. Select the number of inputs and outputs available on the router.

4. Select the type of router.
If the router is not listed, contact Christie Technical Support.

5. For Spyder X20 frames, in the Patch To list select the router protocol.

6. Select the type of connection between the router and Spyder.
Analog is only valid for Spyder X20 frames.

7. Click OK.

Configuring a router
For increased redundancy, configure multiple Spyder systems to share the same physical routing
switcher.

The router patch definition on each Spyder system distinguishes the physical router outputs that
correlate to the Spyder frame inputs.

1. Select Tools > Routers and select the router.

2. Type a name for the router.

3. Select the type of router.
If the router is not listed, contact Christie Technical Support.

4. Select the number of inputs and outputs available on the router.

5. Select the type of connection between the router and Spyder.

6. If the router is an IP router, type the IP address of the router.

7. If the router is a serial router, select the serial port controlling the router.

8. To test the connection to the router, click Query Now.

Creating a custom layout
Create a workspace containing the most relevant windows for your task.

1. Customize the workspace by adding or removing windows.
a) To add a new window, from the View menu, select the window to display.

b) To move a window, click the window title and drag it to the new position.
When dragging a panel over the application, docking handles automatically appear.
Release the mouse while one of the docking handles is highlighted.
To undock a panel, double-click the panel title bar. To re-dock a panel in its last docked
location, double-click the title bar.

c) To resize an area, click and drag the separator bar between the windows.

d) To remove a window, click the X in the top right corner of the window.

2. Save the layout.

• To save the layout as an additional layout, select Layout > Custom Layout > New
Custom Layout. Type a name for the layout and click OK.

• To save it as the new default layout, select Layout > Save as Default.
The default layout is the layout that is loaded when starting Spyder Studio.
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Renaming a custom layout
Change the name of the layout to reflect the tasks that can be performed when it is displayed.

1. Select Layout > Custom Layout > layout name > Rename.

2. Type a new name for the layout and click OK.

Deleting a custom layout
Remove any obsolete layouts.

1. Select Layout > Custom Layout > layout name > Delete.

2. In the confirmation dialog, click Yes.

Switching layouts
Change the organization of the workspace to a different layout.

1. To return to the factory default layout, select Layout > Default Factory Layout > Layout 1.

2. To display the default layout, select Layout > Load Default Layout.

3. To switch to a custom layout, select Layout > Custom Layout > layout name > Load.

Viewing the hardware input allocations
Analyze the Spyder hardware allocations correlated with pixelspace and frame group definitions.

1. Switch to the System Layout view.

2. Verify that the hardware displayed in the System Layout is correct.

3. To understand which inputs and outputs are associated with each pixelspace, review the
hardware allocation mappings.

Viewing the association between layers,
pixelspaces, and outputs
Reference a real-time view of which layers are assigned to a pixelspace, and which outputs display the
pixelspace.

1. Switch to the System Patch view.
Red lines from the layers in the left column identify which pixelspaces they are associated with.
White lines map the pixelspaces with their outputs.

2. To understand which inputs and outputs are associated with each pixelspace, review the
hardware allocation mappings.
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Licensing Spyder
Extend the capabilities of Spyder with licensed options purchased from Christie.

License options are cumulative, meaning that when multiple Spyder frames are connected to a
primary Spyder as expansions, a licensed option must be licensed on every Spyder in the chain or the
option is disabled on all frames.
Licenses are available for the following options:

• Maintenance contract—Maintenance contracts purchased for the Spyder system enable
owners to access software updates containing new features and functionality. A license
containing an active maintenance contract is required to update to new software versions.

• Stereoscopic (SSO)—The stereoscopic option for Spyder allows for any combination of 2D
video inputs and 3D (active or passive) stereoscopic inputs to be displayed on the same screen
simultaneously. Spyder outputs also support passive or active stereoscopic modes, allowing
the device to natively run 3D display devices.

• HDCP—Allows Spyder to stop HDCP-encrypted content from being played on devices that do
not support HDCP or which have been modified to copy HDCP content.

Requesting a license
The license request process generates a snapshot of one or more Spyder frames, which is used by
Christie to generate a license file specifically for the Spyder system(s).

The hardware snapshot is combined with customer information collected during the license request
process to create a packaged license request file.

1. In Spyder Studio, select Help > License Manager.

2. Select Generate a license for my Spyder system and click Next.

3. Complete the customer information fields and click Next.

4. Select whether the request is to license all Spyder systems on the network or just for a specific
server.

5. Specify where the license request will be saved and click Next.

6. Click Generate Now.
The customer information is combined with one or more Spyder hardware snapshots to create
a single file called License.req.

7. After the file is completed generating, click Finish.

8. Email the license request file to techsupport-az@christiedigital.com.

Installing a license file
After receiving a license file, apply the license to Spyder.

1. Copy all license files to a folder on the computer running Spyder Studio.

2. In Spyder Studio, select Help > License Manager.

3. Select Install one or more license packages obtained from Christie and click Next.

4. Browse to the location where the license files are saved.
After selecting the folder, all license packages found in the location are listed at the bottom of
the screen.
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5. Click Next.

6. In the confirmation dialog, click Yes.

7. After the license files are applied, click Next.

8. To close the License Manager, click Next.

Viewing the current license status
Display the current status of all available license options within the Spyder system.

Use the Spyder License Manager to view license status on both primary and expansion Spyder frames.
Because licensed options are cumulative when frames are connected together over the expansion link,
viewing license files on each frame can be useful in troubleshooting licensing issues on expanded
systems.

1. In Spyder Studio, select Help > License Manager.

2. Select View licenses previously applied to my system(s) and click Next.

3. Select the server IP address.
The status of licenses are listed below the server selected.

4. To close the License Manager dialog, click Finish.

EDID management
Learn how to record EDID data from an existing display device, edit EDID data, and program custom
EDID data into the Spyder inputs.
Extended display identification data (EDID) is a data structure provided by a display device to describe
its capabilities to a computer graphics card, enabling a computer to know what kind of monitor is
connected. The EDID includes information such as the manufacturer name and video timings
supported by the display. EDID is defined by a standard published by the Video Electronics Standards
Association (VESA).
As required of all DVI display devices, Spyder DVI inputs conform to the Extended display
identification data (EDID) standard.

Adding an EDID
1. Connect to a remote Spyder frame.

2. Select Server > EDID Manager.

3. Click Add EDID  and select Add from Factory HDMI or Add from Factory DP.

Deleting an EDID configuration
Remove any EDID files that are no longer needed.

1. Connect to a remote Spyder frame.

2. Select Server > EDID Manager.

3. Select the EDID configuration from the list.

4. Click Remove EDID .
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5. In the confirmation dialog, click OK.

Importing an EDID file
Import an existing EDID file to the Spyder frame.

EDID advanced properties can only be edited on imported EDID files with a Christie extension.

1. Connect to a remote Spyder frame.

2. Select Server > EDID Manager.

3. Click Import EDID .

4. Navigate to the EDID file and click Open.

Customizing the EDID properties
To accommodate a display device, it may be necessary to change the EDID settings.

Modifying the EDID settings may result in a file that does not conform to VESA standards, and may
result in performance and quality degradation.

1. Connect to a remote Spyder frame.

2. Select Server > EDID Manager.

3. Select the EDID configuration from the list.
Factory EDID configurations cannot be customized.

4. Modify the base EDID settings.
If the EDID is not for 4K content, deselect the CEA Extension checkbox.

5. To modify advanced properties for the base EDID, at the bottom of the EDID manager, expand
the properties of the configuration and select Base EDID.

6. Select Enable Advanced Properties.

7. In the warning dialog, click OK.

8. Modify the EDID settings.

9. Select the ports to use the selected EDID configuration.
To display ports with connections of a certain type, use the filters.

10. Click Apply.

11. In the confirmation dialog, click Yes.

Retrieving EDID information from the output
Read the EDID information saved on the output, and load it into the EDID manager.

1. Connect to a remote Spyder frame.

2. Select Server > EDID Manager.

3. Click Read EDID from Output .
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Exporting an EDID file
Export an EDID file to an external location.

1. Connect to a remote Spyder frame.

2. Select Server > EDID Manager.

3. Click Export EDID .

4. Navigate to the location where the EDID file will be saved and click Save.

Assigning an EDID file to an input
Identify what EDID file to be used by an input.

1. Connect to a remote Spyder frame.

2. Select Server > EDID Manager.

3. Select the EDID configuration from the list.

4. Select the ports to use the selected EDID configuration.
To display ports with connections of a certain type, use the filters.

5. Click Apply.

6. In the confirmation dialog, click Yes.

Playing HDCP-encrypted content
Configure Spyder to only display content that has made a successful HDCP handshake with the display
device.

High-bandwidth Digital Content Protection (HDCP) is a form of digital copy protection to prevent
copying of digital audio and video content as it travels across a digital interface. The system is meant
to stop HDCP-encrypted content from being played on devices that do not support HDCP or which
have been modified to copy HDCP content.
Spyder has two working modes with respect to HDCP and no combination involves both these modes
at the same time.

• HDCP mode—HDCP-enabled devices can connect and transmit HDCP content to Spyder.

• Non-HDCP mode—This is the normal working mode of Spyder. HDCP content is not displayed.

HDCP has certain considerations and limitations on Spyder, which are imposed by the HDCP
specification implementation and compliance requirements.

• HDCP content is only available through the supported digital interfaces and all analog and SDI
outputs are shutdown but continue to work as if in normal mode.

• Spyder, as an HDCP repeater, can handle a chain of up to seven devices and supports a
maximum of 127 devices. Transmitter devices connected to the Spyder may not have the
capability to support this size of chain, or as many devices. The implementation of the
transmitter determines the impact of going beyond the limits of that device. Spyder does not
have any control if the transmitter chooses not to send HDCP content in such situations.

• In HDCP mode, all downstream traffic from Spyder is encrypted using an HDCP cipher,
irrespective of the nature of incoming video through upstream connections. The upstream
devices may choose to encrypt or not to encrypt the contents based on the type of video
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content but as soon as a device is connected downstream to Spyder, Spyder starts the
authentication process and only HDCP enabled displays or devices function.

• HDCP mode restricts the Spyder outputs to function only in single link mode even for the odd
numbered outputs. In normal mode, odd numbered DVI outputs in Spyder function at dual-link
rates.

• DVI distribution amplifiers, routers, or splitters used in between the sources and Spyder may
be unable to manage HDCP or pass-through the DDC communication with reliability, and the
HDCP connection may break and become unusable.

• After source content is decrypted in Spyder, it may not be retransmitted or output in any
unencrypted signal. HDCP support is system-wide in Spyder, and as a result no supported
scenarios involve simultaneous HDCP outputs and non-HDCP outputs in the same system.

To allow devices to connect and transmit HDCP content to Spyder, enable HDCP.

1. Select Server > Frame Configuration.

2. To allow only DVI outputs which have made a successful HDCP handshake with the
downstream display device to display content, in the Global Settings area select Enable
HDCP.
All other output connectors are disabled.

3. In the confirmation dialog, click Yes.

4. Click Apply Settings Now.

5. Restart Spyder.

Viewing the HDCP status
Identify whether video is being transmitted on the selected output.

1. Open the System Patch view.

2. Locate the output to inspect, and review the LED status indicator.
Each of the outputs completes a handshake with a downstream device before video begins
outputting. Possible status indicators are:

• Green—A successful handshake has occurred and the output is transmitting encrypted
video.

• Amber/Red—The handshake failed and the output is not transmitting video.

Input handshaking status is not available with HDCP devices. As a result, no additional status
information is added for the input or source side of the system.
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Creating a configuration

Use Spyder Studio to design and develop a configuration for the available canvas.

Creating a new Spyder configuration
Create a new project file for each show.

1. Select File > New.

2. In the Welcome Screen, select the type of configuration to start with.

• Start with new empty configuration—Build a new configuration.

• Load current configuration—Create a new configuration file using the settings from the
last project loaded into Spyder Studio.

3. Add the Spyder frames to be used in the configuration.
Select the model of each Spyder frame and the IP address of the frame in the order it will
appear in the expansion chain.

4. Select the frame rate and mode for the Spyder system.
To create a 3D configuration, select Stereoscopic mode.

5. Select the pixel depth model.

6. To include a Preview area in the configuration, click Preview Disabled.
The button changes to Preview Enabled.

7. Click Next.

8. Define the canvas for each frame in the configuration.
a) Set the width and height of the canvas space.

b) Identify the starting position of the canvas.

9. Click Next.

10. Add pixelspaces to the canvas.
a) To add a pixelspace, right-click within the grid and select Add Pixelspace.

b) Select the new pixelspace and adjust the size with the pixelspace boundary handles or by
specifying the width and height in pixels in the top toolbar.

c) Click and drag the pixelspace to the correct position on the grid.
The location can also be specified by entering the X and Y position of the pixelspace in the
top toolbar.

d) To rename the pixelspace, in the pixelspace properties pane type a new name and press
Tab.

e) To remove a pixelspace, right-click the pixelspace and select Remove.
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11. Click Next.

12. Select an output and drag it onto the pixelspace.

13. To configure the output, select it on the canvas and in the Properties pane adjust the output
settings.

14. Click Next.

15. Select which data types within the configuration to keep and remove from the new
configuration.

16. Add a router to the configuration.
Routers can also be added after the configuration has been created.

17. Click Next.

18. Apply the configuration.

• If the computer is connected to Spyder, select Apply to Spyder hardware now.

• If the computer is not connected to Spyder, select Apply to local PC now (Virtual
Mode).

19. In the confirmation dialog, click OK and Close.
Updates to Spyder the may cause devices in the expansion chain to restart.

Related information

Opening a project file saved on the computer (on page 19)

Saving a project file to the computer
When creating or updating a project while disconnected from Spyder, save the project file on the
computer.

1. Select File > Backup.

2. Navigate to the location where the file will be saved.

3. Type a name for the project file.

4. Click Save.
Spyder Studio projects are saved with a .vap extension.

5. Select whether the still images in the configuration should be included.
Including still images in the backup may significantly increase the size of the file.

Opening a project file saved on the computer
Load a previously created project into the Spyder Studio workspace.

1. Select File > Restore.

2. Navigate to the location where the file was saved.

3. Select the file and click Open.
The project files is loaded into the Spyder Studio workspace.
If the computer running Spyder Studio is connected to a Spyder, the configuration is also
pushed to the server.

Related information
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Loading a project file onto the Spyder (on page 20)

Retrieving the configuration on Spyder
Download the configuration currently loaded on Spyder into the Spyder Studio workspace.

1. Save the configuration file currently active in Spyder Studio.
The configuration downloaded from the server automatically overwrites any configuration in
the software, regardless of whether any changes have been saved.

2. Select Server > Pull Data from Server.

3. Optionally, save a copy of the server configuration to the computer.

Related information

Saving a project file to the computer (on page 19)

Loading a project file onto the Spyder
Move the project file saved on the computer onto Spyder.

If the computer is connected to Spyder, restoring a configuration file automatically pushes the
configuration to the server.

1. When disconnected from the server, open the configuration file in Spyder Studio.

2. Connect to Spyder.

3. Select Server > Push data to server.

Related information

Opening a project file saved on the computer (on page 19)

Adding a preview to a configuration
Add a preview pixelspace to a configuration after the configuration wizard has been completed.

1. In the System Patch view, right-click the center column of pixelspaces and select Add.

2. Select Add a Preview pixelspace for an existing pixelspace.

3. In the properties area, select which pixelspace to create a preview for.

4. Click OK.

Adding a pixelspace
Configure the size and position of the pixelspace required for the configuration.

1. In the System Patch view, right-click the center column of pixelspaces and select Add.

2. Select Add a New Program pixelspace.

3. In the properties area, define the name, position, and size of the new pixelspace.

4. If the pixelspace is being added to a parallel configuration, identify the Spyder frame it will be
controlled by.

Creating a configuration

Spyder Studio User Guide 20
020-102579-01 Rev. 1 (07-2017)
Copyright © 2017 Christie Digital Systems USA Inc. All rights reserved.



5. Click OK.

Pixelspace and layer alignment
Understand the alignment options available for pixelspaces and layers

Icon Description

Align Bottom—Repositions specified layers vertically to make the bottom edge of the layers
match the first specified layer.

Align Center—Repositions specified layers horizontally to make the center position of all layers
match the first specified layer.

Align Left—Repositions specified layers horizontally to make the left edge of all layers match
the first specified layer.

Align Middle—Repositions specified layers vertically to make the center position of all layers
match the first specified layer.

Align Right—Repositions all specified layers horizontally to make the right edge of all layers
match the first specified layer.

Align Top—Repositions specified layers vertically to make the top edge of layers match the first
specified layer.

Center Horizontal—Repositions all specified layers as a group so that layers are centered
horizontally in their current pixelspace.

Center Vertical—Repositions all specified layers as a group so that layers are centered
vertically in their current pixelspace.

Horizontal Decrement—Decreases the horizontal spacing between two or more layers.

Horizontal Increment—Increases the horizontal spacing between two or more layers.

Make Horizontal Equal—Makes the horizontal spacing between all specified layers equal to the
spacing between the first and second specified layers.

Make Same Height—Makes all specified layers the same height as the first specified layer,
maintaining aspect ratio in all layers.

Make Same Width—Makes all specified layers the same height as the first specified layer,
maintaining aspect ratio in all layers.

Make Vertically Equal—Makes the vertical spacing between all specified layers equal to the
spacing between the first and second specified layers.

Remove Horizontal Spacing—Removes spacing between specified layers, causing them to be
horizontally stacked in the order specified.

Remove Vertical Spacing—Removes spacing between specified layers, causing them to be
vertically stacked in the order specified.

Size to Display Height—Resizes specified layers to fill their respective pixelspace vertically; no
adjustment is made to the horizontal position.

Size to Display Width—Resizes specified layers to fill their respective pixelspace horizontally,
and centers the input vertically.
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Icon Description

Snap to Bottom—Repositions specified layers vertically to align bottom edges of layers with the
bottom of their pixelspace.

Snap Left—Repositions the specified layers horizontally to align left edges of layers with the left
edge of their pixelspace.

Snap Right—Repositions the specified layers horizontally to align right edges of layers with the
right edge of their pixelspace.

Snap Top—Repositions the specified layers vertically to align top edges of the layers with the
top edge of their pixelspace.

Stack Grid—Arranges the layers in the grid configuration selected, and sizes the layers based
on the grid alignment options.

Stack Horizontal—Makes all layers the same height, centers them vertically with the first
specified layer, and positions them in a horizontal array running to the right of the first layer.

Stack Vertical—Makes all layers the same width, centers them horizontally with the first
specified layer, and positions them in a vertical array running downward starting at the first
layer’s position.

Swap Windows—Swaps horizontal position and size between the two specified layers.

Vertical Decrement—Decreases the vertical spacing between two or more layers.

Vertical Increment—Increases the vertical spacing between two or more layers.

Configuring an output
To ensure all content has a consistent appearance, adjust how content appears when displayed
through a specific output.

1. In the System Patch view select the output to adjust.

2. In the Properties pane adjust the output settings.

3. Right-click the output and select Set as Configuration Output.

Adding a still image
Spyder works with most standard image formats, including .png, .jpg,. gif, .jpeg, .tiff, .tga, .dds, .dib,
or .bmp.

Video and images may have an alpha channel that identifies the transparency applied to the red,
green, and blue color channels. Images that contain an alpha channel must be saved in a format that
maintains the alpha channel data, such as .png or .tiff.

1. Switch to the Stills tab.

2. Right-click a spot and select Add File(s).

3. Browse to the image location and select the image.

4. Click Open.
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Synchronizing images between the client and server
Compare and update any still image files out of sync between the client and server.

1. On the Stills view, right-click the image and select Sync Files.

2. Select whether the image on the client is uploaded to the server, or the server image is
downloaded to the client.

3. Select what should happen to any image that does not have an associated register.

4. To view what the results of the synchronization will be, click Preview.

5. To start the synchronization, click Perform Sync Now.

6. After the synchronization is complete, click Close.

Adding a source
Add the video sources needed for the configuration.

1. Make sure the system is physically connected with power to all sources.
Always double check connections and ensure that each source is on the correct input, and the
source is powered on and outputting a video signal.

2. Click inside an empty source row.
Alternatively, if an existing source has a configuration similar to the new source, right-click the
similar source and select Copy Source.

3. Type a name for the source.

4. Select the input type.

5. Identify the router.

• If the source is connected directly to Spyder, select Spyder Internal and specify the
physical input number that the source is patched to.

• If the source is using a router controlled by Spyder, select the router from the list.

• If the connected router is not yet defined on Spyder, above the router list, click Add.

• If no router is used, select Remove.

6. Select the stereo mode.

• Off—The source is non-stereo input.

• Active—Define a router and associated input for the stereo sync signal, which can be
routed separately from the video signal.

• Passive—Define a second router input which specifies the input of the alternate eye video
signal.

7. Select the input configuration.

• New—Create a completely new configuration.

• Copy—Create a configuration from an existing configuration.

• Link—Associate the new source to an existing input configuration.

8. To add the source without any further configuration, right-click in the Sources area and select
Add new Source.
Alternatively, to continue configuring the input, click Create and Configure Input.
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Configuring the source
Change the name, select the router, and set the preferred treatments and layers for the source.

1. Make sure the system is physically connected with power to all sources.
Always double check connections and ensure that each source is on the correct input, and the
source is powered on and outputting a video signal.

2. Click an existing source.

3. In the Properties view, configure the following settings:

• Name—Type a name for the source.

• Thumbnail—Select an image to represent the source in the source list.

• Preferred Treatment—Associate an image file to represent the source within the Spyder
Studio. Optionally, specify a treatment to automatically be applied to a layer when the
source is selected.

• Preferred Layer—Specify a layer to be used when opening the source in a new layer. If
the requested layer is in use when the source is recalled, the first available layer is used
instead.

4. Identify the router.

• If the source is connected directly to Spyder, select Spyder Internal and specify the
physical input number that the source is patched to.

• If the source is using a router controlled by Spyder, select the router from the list.

• If the connected router is not yet defined on Spyder, above the router list, click Add.

• If no router is used, select Remove.

5. Select the hardware input connector number.

6. To automatically detect the type and properties of the video source, select <AutoSync>.

7. On the Preferences tab, select the preferred treatment and layer for the source.

8. To add the source without any further configuration, select Create and Add Another Source.
Alternatively, to continue configuring the input, select Create and Configure Input.

Configuring the source input
Set the parameters for the input.

1. Right-click a source and select Configure Input.

2. Open the Input Configuration section.

3. To automatically examine the source and locate the best match in the default resolution tables,
click Auto-Sync.

4. To manually configure the resolution for the source, click Load Standard and select the
resolution from the list. Click Apply.

5. To adjust the raster, use the arrows to fit the source into the raster box.

6. Click Save.

Creating a configuration

Spyder Studio User Guide 24
020-102579-01 Rev. 1 (07-2017)
Copyright © 2017 Christie Digital Systems USA Inc. All rights reserved.



Creating cut and fill sources
Use cut and fill sources to create non-rectangular shapes.

A linear key is comprised of two video sources, known as a cut signal and a fill signal. The fill signal is
the source video material intended to be shown on screen. The cut signal removes the luminance
(green) channel, leaving only the content to be displayed over top of the fill signal.
The resolution of the cut and fill layers must be exactly the same.

1. Create a cut source.
a) Add a new source.

b) In the Input Configuration properties, switch to the Keying tab and select Cut.

c) Click Save.

2. Create a fill source.
a) Add a new source.

b) In the Sources area, switch to the Linear Key tab and select the cut source created in
step 1.

c) In the Input Configuration properties, switch to the Keying tab and select Fill.

3. Add the fill source to a layer in the pixelspace.
Even though two sources are being used to create the shape, only one layer is consumed.

Adding content to the pixelspace
Add the video sources and still images to the pixelspaces.

1. In the Simulator area, in View Stack select the pixelspace to display.

2. Click and drag the source or still into the pixelspace.
Dragging a source or still onto an existing layer causes the source or still to be loaded to the
layer directly. Dropping a source or still on a pixelspace causes an unused layer to be displayed
and loaded with the specified source or still.
Layers are added to a pixelspace starting with Layer 1. Layers are displayed with the highest
number layer appearing on top of lower number layers.
On Spyder X20, when using a preview pixelspace, Christie recommends loading a still into the
preview pixelspace and then transitioning to program.

3. To assign a source or still to a specific layer, right-click in the pixelspace and select Add Layer.

4. Select the layer to add and drag the source into the new layer.
To add a source displayed as a single item across all pixelspace, add the source or still to All
pixelspace.

5. To remove a layer from the pixelspace, right-click the layer and select Remove Selected.

6. To remove all layers from the pixelspace, right-click in the pixelspace and select Remove All
Layers.

Moving a layer to a different pixelspace
To move a layer to a different area of the canvas, you may need to change the pixelspace the layer
belongs to.

1. In the Simulator area, in View Stack select the pixelspace to display.
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2. Right-click the layer, select Move to pixelspace and choose the pixelspace from the list.

3. To remove a layer from the pixelspace, right-click the layer and select Remove Selected.

4. To remove all layers from the pixelspace, right-click in the pixelspace and select Remove All
Layers.

Changing the size and position of a source
Move the layer to a different location in the pixelspace or adjust the size of the layer.

1. In the Simulator area, select the layer.

2. Expand KeyFrame.

3. To change the size of a layer, click and drag the corner of the layer.

4. To change where the layer appears, click and drag the layer into the new position.

5. Alternatively, modify the keyframe properties for the position and size of the layer.
a) In the Simulator area, select the layer.

b) Expand the KeyFrame properties.

c) To change the size of the layer, in the Size/Position area type the width.
The height is automatically adjusted to maintain the aspect ratio of the source.

d) To change where the layer appears, in the Size/Position area type the coordinates for the
X (horizontal) and Y (vertical) position.

Replacing the source or still image in a layer
Change the source displayed in a layer.

1. In the Simulator, select the layer.

2. To replace the source, double-click the new source.
Alternatively, click and drag the new source onto the layer.

3. To put a still image into a layer, click and drag the still image onto the layer.

Adding a background to a pixelspace
Add a static image, such as a corporate logo, as the background of a pixelspace.

1. Inside the pixelspace, right-click and select Next Background or Current Background.

2. Select the graphic or color to use as the background.

• To add a new image as a background, click Browse File and navigate to the new image.

• To use a solid color as the background, click Browse Color and select the color to display.

• From the list, choose a graphic or file that has already been used as a background.

3. To remove the background, right-click inside the pixelspace and select No Background.
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Displaying a test pattern
Set test patterns for each pixelspace and output to assist with the configuration and to diagnose any
issues that may occur.

The test pattern for each pixelspace or layer must be configured individually.

1. In the Simulator area, select the layer or pixelspace.

2. Expand Test Pattern Generator.

3. Select the pattern and type of test pattern to display.

4. Select the additional pattern overlay options for the test pattern.

• Outline—Draws a 1-pixel white outline around pattern.

• Center—Draws a 1-pixel circle filling the pattern raster.

• Grid—Loads a white grid over the selected pattern.

• Center X—Draws an X from corner to corner of image.

5. To display the test pattern on the layer or pixelspace, click Load.

Cloning or mirroring a layer
Create a copy of a layer that shares all keyframe properties with the original layer such as size,
border, and shadow settings, with the exception of the horizontal position.

The clone can exist anywhere on a horizontal offset from the original layer, however the clone cannot
be positioned at a vertical offset. This is useful for widescreen applications where the same video
source must be repeated on each side of the screen.

1. In the Simulator area, select the layer.

2. In the Properties area, expand KeyFrame and select the preferred Clone option.

• Mirror—The clone moves in a mirror image to the original layer. If the original layer is
moved towards the clone layer, the clone layer moves towards the original layer. If the
original layer is moved away from the clone layer, the clone layer moves away from the
original layer. This only occurs on the horizontal plane. The layer always stay at equal
height, in respect to each other, vertically.

• Offset—The clone always stays the same distance from the original on the horizontal
plane. If the original layer is moved towards the right, the clone moves the same distance
to the right. This only occurs on the horizontal plane.

3. For an Offset clone, adjust the distance between the original and clone layer.

4. To remove a cloned or mirrored layer, select Off.

Adjusting the brightness, contrast, hue,
saturation, and gamma of the source
Improve the image quality by changing the brightness, contrast, hue, saturation, and gamma levels.

1. In the Simulator area, select the layer.

2. In the Properties area, expand Input Configuration.
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3. On the Levels tab, use the sliders or type a value for the brightness, contrast, hue, saturation,
and gamma.

4. To reset the values, click Defaults.

5. Click Save.

Adjusting the darkness or color of the source
Remove user-defined portions of a live video input signal, allowing for visual effects such as non-
rectangular windows and titling.

1. In the Simulator area, select the layer.

2. In the Properties area, expand Input Configuration.

3. On the Keying tab, select the Key Mode.

• Luma—Clips pixels that are below a user-defined darkness threshold away from the
source image .

• Color—Clips pixels within a user specified threshold from a specific color from the source.

• Cut and Fill—Allows for non-rectangular shapes to be created.
A linear key is comprised of two video sources, known as a cut signal and a fill signal. The
fill signal represents the source video material intended to be shown on screen. The
luminance (green) channel of the cut signal is used as a real-time video mask. Control is
provided with the linear key as the video input used to generate the cut is a different video
signal.
A linear key requires two adjacent Spyder layers and the cut signal must be provided on
the lowest of the two layers.

4. To reset the values, click Defaults.

5. Click Save.

Related information

Creating cut and fill sources (on page 25)

Changing the look of a layer
Alter the way the layer appears when it is displayed, without changing the original source by creating
treatments.

A treatment is a collection of key frame information that can be applied to one or more layers in the
system at any time. Treatments offer a considerable speed increase over manually adjusting the key
frame for a layer and make it easy to provide a consistent look between windows. A default treatment
can even be selected, extending the consistent look of multiple layers by automatically applying a
treatment to all layers before they are displayed on screen.

Adding borders to a source or still
Place borders around each layer or source to accent or differentiate it.

1. In the Simulator area, select the layer.

2. Expand the Border/Shadow properties.

Creating a configuration

Spyder Studio User Guide 28
020-102579-01 Rev. 1 (07-2017)
Copyright © 2017 Christie Digital Systems USA Inc. All rights reserved.



3. Configure the thickness, offset, and settings for the border.

• Thickness—Defines the thickness of the border around the layer. When adjusting the
thickness, the layer content is scaled to fit within the border.

• Offset—Adjusts the appearance of a horizontal or vertical angled lighting effect.

• Inside Soft—Identifies the degree to which the inside border softens and blends with the
content. As a border is softened, it becomes less defined on the outside edges.

• Outside Soft—Identifies the degree to which the exterior border softens and blends. The
affected edges can be selected.

4. Switch to the Fill tab and select a color or texture for the border.

5. To define the shape of the border, switch to the Shape tab and select the shape.

Adding a shadow to a source or still
Control the shadow properties on the layer, providing a more 3D look to an otherwise flat layer.

1. In the Simulator area, select the layer.

2. Expand the Border/Shadow properties.

3. Configure the thickness, offset, and settings for the shadow.

• Offset—Adjusts the distance and direction of the shadow from the layer, allowing the
shadow to be positioned anywhere around the layer.

• Size—Defines the width of the shadow. A larger shadow gives the visual effect of the layer
appearing further away from the background content.

• Softness—Softens the edges of the shadow, providing a harder or more subdued shadow
effect.

• Transparency—Sets the overall darkness of the shadow. The adjustment range is from 0
(black) to 255 (transparent).

4. Switch to the Fill tab and select a color for the border.

5. To define the shape of the border, switch to the Shape tab and select the shape.

Changing the area of interest in the layer
Move the area of interest within the input with zooming and panning.

1. In the Simulator area, select the layer.

2. Expand the KeyFrame properties.

3. In the Attributes area, switch to the Pan & Zoom tab.

4. To zoom in on the area of interest, adjust the slider.

5. To move the area of focus into the center of the layer, adjust the horizontal and vertical sliders.

6. To remove any pan or zoom settings, click Reset.

Cropping a layer
To crop part of the image, use the sliders for each edge of the selected layer.

1. In the Simulator area, select the layer.

2. Expand the KeyFrame properties.
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3. In the Attributes area, switch to the Crop tab.

4. To crop the edges of the selected layer, use the sliders.
Crop adjustments are represented in decimal format, with values between 0.0 (no crop) and
1.0 (full crop).

5. To remove any cropping, click Reset.

Changing the aspect ratio of a layer
Adjust the aspect ratio in the source input configuration to override the original aspect ratio.

1. In the Simulator area, select the layer.

2. Expand the KeyFrame properties.

3. In the Attributes area, switch to the A/R tab.
The total aspect ratio adjustment includes any adjustments configured in the Input
Configuration properties.

4. Adjust the Offset setting until the preferred aspect ratio is displayed, or type the required
aspect ratio.

Transitioning from one keyframe to another
Set the duration of the transition (in frames) for live layer transition operations such as mixing a layer
on or off screen.

1. In the Simulator area, select the layer.

2. Expand the KeyFrame properties.

3. In the Attributes area, switch to the Motion tab.

4. To configure transitions for this layer, deselect Use System Defaults.

5. To change the amount of time it takes to display or remove the layer, adjust the Ease In and
Ease Out sliders.

Saving a treatment
Save the border, shadow, and keyframe settings as a treatment to be applied to other layers and
sources.

1. Right-click on the layer with the treatment to save and select Treatments > Save As
Treatment.

2. Type a name for the treatment.

3. Select the options to save as part of the treatment.

4. Click OK.
Saved treatments are listed in the Treatments view.

Related information

Applying a treatment to a layer (on page 31)
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Applying a treatment to a layer
Alter the way the layer appears when it is displayed, without changing the original source.

1. To apply a treatment to a single layer, drag the preferred treatment from the treatment list
onto a layer in the simulator or patch control.
Alternatively, select the layer and in the Treatments view double-click the treatment name.

2. To apply a treatment to multiple layers simultaneously, select the layers and double-click the
preferred treatment.
When applying a treatment to multiple layers, a dialog may appear requesting confirmation.

3. To apply treatments to script elements, drag the treatment from the treatment list onto a
script element at the preferred cue location.
If a keyframe is already defined at the selected element cue, the treatment is applied to the
existing element keyframe properties. If no keyframe exists at the specified location, a new
keyframe is automatically added to the element.

4. To remove a treatment from a layer, right-click the layer and select Treatments > Clear
Treatment.
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Scripting a
configuration

Spyder Studio scripting provides a powerful environment for creating elaborate visual effects, such as
walk-on looks for staging events and looping demonstrations.

Every command key is based on a script file. A script consists of displays various sources or stills,
referred to as elements, which span a period of time in the form of cues.

Creating a function key
Function keys provide single step operations that can be recalled manually or linked to command keys.

1. Right-click in an empty area of the Function Key area and select the type of key to add.

• Background mix—Mixes backgrounds between programs and preview.

• External Command Key Recall—Recalls a command key on a remote Spyder.

• Layer Freeze—Freezes the source within a layer.

• Device Freeze—Freezes the source by device.

• Layer Offset—Defines horizontal and vertical offsets to be applied to one or more
windows. This is typically used to create Fly Off effects.

• Network Command—Sends a single UDP or TCP string in ASCII format to a user-
specified port, at a user-specified IP address.

• Router Salvo—Switches outputs on a router not directly connected to Spyder.

• Source Assignment—Loads a defined source onto one or more layers.

• Still Load—Loads a still on a layer.

2. Type a name for the function key and click OK.

3. Select the function key and enter the required information in the Properties area.
For network command keys, special values can be entered into the command line using the
following escape codes:

• \r—Sends a carriage return character.

• \n—Sends a new line character.

• \X00—Sends a hex character, where the 00 represents a hex encoded value.
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Creating command keys
Create preset user-defined screen looks to be recalled or added to a script.

The number of command keys displayed in the panel is user definable and up to 20 pages of command
keys can be created.

1. Create the look for the command key in the Preview or Program simulator area, including any
layers or treatments.

2. Right-click in an empty area of the Command Key view and select the source of the settings.

• Empty—Creates an key with no content in the Program or Preview areas, used to clear all
pixelspace.

• From Screens—Saves the layers and settings in the Program area.

• From Preview—Saves the layers and settings in the Preview area.

• From Program—Saves the layers and settings in the Program area.

• Add Multi key—Saves the layers and settings in the Program area.

3. Type a name for the key, and click OK.

4. Right-click the command key and select whether it is relative or absolute.

• Relative—Replaces any layers of the same number with the content and position for the
command key. Any unique layers from the previously displayed command key remain on
the pixelspace.

• Absolute—Replaces any layers of the same number with the content and position for that
command key. Any unique layers from the previously displayed command key are
removed from the pixelspace.

5. To send the command key settings to the Preview area of the Simulator, click PVW.

6. To send the command key settings to the Program area of the Simulator, click PGM.
Command keys remain in edit mode after selected until either they are disconnected in the
Command Key window or until another command key is recalled that takes control of all layers
in the original command key.
If a command key shows red in Program or yellow in Preview, the command key is in edit
mode and any changes to layers are saved in that command key.

7. In the Properties area of the command key, set the clock source for a command key.

Setting a command key as relative or absolute
Identify whether or not the content of a command key overwrites the settings of another command
key when moved to the Program or Preview view.

Absolute and relative command key modes differ in the handling of layers not defined specifically as
part of the command key.

1. In the Command Key area, locate the command key in the list.

2. Right-click the command key and select Make Relative or Make Absolute.

• Relative—Replaces any layers of the same number with the content and position for that
command key. Any unique layers from the previously displayed command key remain on
the pixelspace.
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• Absolute—Replaces any layers of the same number with the content and position for that
command key. Any unique layers from the previously displayed command key are
removed from the pixelspace.

Adding elements to a script
A script element represents one or more layers of the system spanning two or more cues, including
sources, stills, and mixers.

1. Add an element to the script by dragging a source or still from a content panel onto the script.
The element is automatically added at the location of the drop cue, starting on the drop layer.

2. To add keyframe to an element, right click the element at a cue location, and select Add
KeyFrame.
By default, elements only contain one keyframe which defines the initial location of the
element on screen. As the script advances, each element uses the last defined keyframe.
When editing the keyframe of a layer defined as a script element, the element is automatically
updated.

3. To adjust the cue length, drag the bottom edge of the element to the appropriate end point.

4. To create a mixer out of a script element, right-click the element and select Convert to Mixer.
To mix sources in one window, add multiple sources into the same element at different cues.

5. To display two sources simultaneously out of a script element, right-click the element and
select Convert to Input Array.
With this configuration, if one source is not ready, the other source waits until that source is
ready to be displayed.

6. To add an off element to a script, right-click in an empty area of the script grid and select Add
Off Element.

7. To configure the script elements, select the element and modify the parameters in the
properties area.
Properties that can be modified include the entrance and exit duration, the size and location of
the element, and the settings overridden for slave layers.

Adding a trigger to a script
Cue triggers automate the execution of a script cue, based on the internal clock for Spyder, or an
external time source.

1. In the left column of the script window, select the cue.

2. In the properties area, select and configure the trigger.

• Wait—Counts down a specified number of frames and execute the next script cue. To
automate multi-step scripting operations, create multiple wait triggers on subsequent
cues.

• WaitX—Counts down a number of frames until the next cue is manually executed. The
script engine then automatically records the elapsed time and changes the cue trigger
type from WaitX to Wait. Subsequent executions of the script cue function as a standard
wait trigger.

• Time—Monitors an external clock source for a user-defined time code and executes the
next cue. The external clock source must be provided from a device connected to the
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playback controller and must support a standard playback machine protocol such as
BVW75 or Odetics.

• Time of Day—Monitors an external clock source for a user-defined time code and days of
the week, and executes the next cue.

Controlling playitems
To achieve granular control and management of tightly coupled timed events, spanning multiple
discreet components, add playitems to scripts or call scripts from playitems.

Adding a PlayItem
Create a pre-configured segment of video playback.

1. To open the playitems view, select View > Play Items.
The playitems list displays the current status for all playitems.

• Inactive—Not currently running but the in-point and total running time (TRT) are
displayed.

• Cued—Cued to the in-point time code, minus the preroll frames.

• PreRoll—Started playing but the in-point time has not yet been reached. The preroll
counts down the amount of time remaining before the in-point time is reached.

• Playing—Currently playing and has passed the in-point time. The amount of time
remaining before the out-point is reached is displayed.

• RollOut—Passed the out-point time and is continuing to play until the time code has
reached the out-point time plus the rollout frame count.

2. In an empty row, right-click and select Add.

3. Type a name for the playitem and click OK.

4. In the Default Source field, select the source name used for the element created when the
playitem is added to a script.

5. Select the image to display as a thumbnail representing the playitem.

6. Select the playback device ports active for this playitem.
Two groups of buttons, labeled 1-4 and 5-8, select a playback device port. All controls in the
Machine section of the property panel (timecode, live controls, and configuration) follow the
selected port.
Ports 1-4 refer to the four ports on a playback device configured as a primary. Ports 5-8 refer
to the four ports on a playback device configured as an expansion. The primary/expansion
selection is set physically on the playback device hardware.

7. Select the playback device.
a) Click Show Configuration.

b) Select the playback device.

c) Select Enabled.

d) Click Apply.

8. Define the start and end point, lead-in time, and lead-out time for the PlayItem.

• PreRoll—The number of frames required as lead-in time to reach normal playback speed.
Usually required for tape-based playback devices but can be used as a lead-in time when
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mixing on a Spyder layer at the beginning of playback. The playitem is cued to the
specified in-point time minus the number of preroll frames.

• RollOut—The number of frames to run past the out-point time before actually stopping
the device. Use this as a lead-out time when mixing off a Spyder layer at the end of
playback.

• In Point—The device time code where the playitem video should start playing. To insert
the current time code from the machine area of the panel into this field, click Mark.

• Out Point—The device time code where the playitem video should stop playing. To insert
the current time code from the machine area of the panel into this field, click Mark.

9. In the Machines area, define one or more machines to be controlled as part of the selected
playitem.
a) Select the overall frame rate for the playitem timecode countdown within Spyder.

This should usually match the frame rate of the first selected deck in this panel section.

b) Select the playback device ports to be controlled as part of the playitem.
At least one port must be checked for the playitem to be considered valid, and multiple
decks can be selected for sync-roll operations.

Multiple machine selections are typically used for sync-roll operations, where the content of
multiple decks are combined to create large, high resolution video playback. When multiple
decks are selected in a single playitem, all decks receive cue, stop, and play commands
simultaneously, enabling all operations to be triggered at the same time on all devices.
In cases where long running sync-rolls are preferred, clock skew between the decks may cause
drifts in the time code between the decks. In these cases, a timecode chase or genlock may be
required between the decks.

10. When controlling clip-based playback devices, specify the clip loaded when recalling the
playitem.
If this field is not specified, or if the deck protocol used does not support clip control, no clip is
recalled when the playitem is cued.

Manually controlling a playitem
Manually play, stop, cue, and jump to points in the playitem.

1. To open the playitems view, select View > Play Items.
The playitems list displays the current status for all playitems.

• Inactive—Not currently running but the in-point and total running time (TRT) are
displayed.

• Cued—Cued to the in-point time code, minus the preroll frames.

• PreRoll—Started playing but the in-point time has not yet been reached. The preroll
counts down the amount of time remaining before the in-point time is reached.

• Playing—Currently playing and has passed the in-point time. The amount of time
remaining before the out-point is reached is displayed.

• RollOut—Passed the out-point time and is continuing to play until the time code has
reached the out-point time plus the rollout frame count.

2. Right-click a playitem and select the preferred action.
Alternatively, select the playitem and in the Properties area select the playitem control action.
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3. To adjust the clip out point without the requirement of viewing the entire length of the
playitem, cue the playitem with a Jump To time of 10-180 seconds from the out point.

Moving playitem into a script cue or layer
To associate playitem with command key scripts, drag and drop play items between the playitem panel
and the script panel.

1. Drag a playitem to a script cue.
Each cue in a command key script has properties specific to that cue, including cue, play, or
stop one or more existing playitem. Whenever defined on a cue, a specified playitem operation
is executed whenever the associated script cue is executed.
When dragging a playitem onto a cue in the script window, a playitem cue command is added
one cue before the cue dropped on, and the dropped cue adds a playitem play command and a
time trigger that automatically advances the script at the end point of the playitem. The clock
source for the script is set to the first machine port defined in the playitem.
The playitems area of the cue properties automatically expand as additional playitems are
defined, allowing an unlimited number of playitem commands to be added to the cue.

2. Drag a playitem to a script layer.
Dragging a playitem to an unused area within the script grid complete the same operations
dragging a playitem onto a script cue, and additionally a source element is created with the
default source defined on the playitem.

Related information

Creating a custom layout (on page 11)
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Maintaining and
monitoring Spyder

Learn how to monitor and perform maintenance on Christie Spyder.

Viewing alerts
Display real-time diagnostic information for both Spyder Studio and a connected Spyder server.

The Alert Viewer provides visibility into the Spyder system and is useful for troubleshooting application
or general system problems. The Alert Viewer tab shows a list of informational, warning, and error
messages that occur in both Spyder Studio and a remotely connected Spyder frame.
Anytime Spyder Studio performs a significant action or any time a connected Spyder system
encounters an error, an entry is logged in the Alert Viewer panel.

1. Open the Alert Viewer view.

2. To view the details of an alert, double-click the row.

Clearing the log files
Remove all log entries from the Alert Viewer.

1. Open the Alert Viewer view.

2. Click Clear Logs.
The entries in the Alert view are removed immediately.

Saving the log files
Export the log files to a text file that can be referenced during troubleshooting.

1. Open the Alert Viewer view.

2. Click Save to Disk.

3. Type a name for the text file and click Save.

Upgrading the firmware on the Spyder
In the list of devices on the network, any server colored orange requires a firmware update.

1. Open Spyder Studio.
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2. Select Server > Connection Manager
The server connection manager displays all individual Spyder frames or primary frames
available on the network. Spyder frames configured as expansion frames do not appear in the
server connection dialog.

3. In the Current Connection area, select the Spyder colored orange and click Update Now.

4. In the confirmation dialog click Yes.
The hardware is updated.
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Glossary

1080p
1080p is the Advanced Television Systems
Committee (ATSC) high definition 1920 x 1080
progressive scan video format in which a
complete frame of video is delivered at either 60
or 24 frames per second.

4K
A display specification that is capable of
displaying 4096 x 2160 resolution, or
approximately 8.85 million pixels.

Active stereoscopic display
Powered glasses that present the image intended
for the left eye while blocking the view of the
right eye, then presenting the right eye image
while blocking the left eye. This cycle is repeated
rapidly, so that the two images combine into a
single 3D image.

Aspect ratio
The ratio of the width of an image to its height,
such as the 4:3 aspect ratio common in video
output. Can also be expressed as a decimal
number, such as 1.77, 1.85 or 2.39. The larger
the ratio or decimal, the wider and less square
the image.

Brightness (perceived)
The human eye responds to low light levels by
enlarging the pupil, allowing more light to enter
the eye. This response results in a difference
between measured and perceived light levels. The
brightness of a projection system can be precisely
measured with a light meter; however, the
human eye has a logarithmic response to light. A
lamp that is dimmed to 10% of its maximum
measured light output is perceived as being
dimmed to only 32%. Likewise, a lamp dimmed
to 1% is perceived to be at 10%.

Color temperature
The coloration (reddish, white, bluish, greenish,
and so on.) of white in an image, measured using
the Kelvin (degrees K) temperature scale.

Contrast (ratio)
The degree of difference between the lightest and
darkest areas of the image.

DisplayPort
A digital display interface primarily used to
connect a video source to a display device such
as a computer monitor, though it can also be
used to transmit audio, USB, and other forms of
data. DisplayPort can be used to transmit audio
and video simultaneously.

DVI
Digital visual interface. A standard that defines
the interface between digital devices such as
projectors, flat screens and personal computers.
For devices that support DVI, a digital-to-digital
connection can be made to eliminate the
conversion to analog and deliver an image.
DVI can also carry an analog signal and comes as
DVI-I (integrated—analog and digital), DVI-D
(digital only) and DVI-A (analog only).

E-EDID
Enhanced extended display identification
standard. Enables properties (such as resolution)
of a display device to be detected by the display
card in a controlling device such as a PC. The PC,
in turn, can then output in a matching format to
fill the display.
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Gamma
The relationship between input video voltage and
output brightness, which determines how mid-
tones appear.

HDCP
High-bandwidth digital content protection.
Prevents copying of digital audio and video
content as it travels across connections.

Input
A physical connection route for a source signal.

Input signal
Signal sent from a source device to the projector
or display.

Keyframe
Visual attributes applied to a layer such as size,
position, borders, shadows, or clone modes.

Passive stereoscopic display
Two images are projected superimposed onto the
same screen through polarizing filters or
presented on a display with polarized filters. The
viewer wears glasses which also contain a pair of
opposite polarizing filters. As each filter only
passes light which is similarly polarized and
blocks the opposite polarized light, each eye only
sees one of the images.

Pixel
The smallest discernible element of data from a
computer-generated image.

Pixelspace
A clipping rectangle defining an area of the
screen.

Preset
A set of layers and treatments to be displayed
within a pixelspace.

Output
A physical connection route for sending a signal
to a projector or display.

Layer
A single input, displaying either a live video input
or a still image.

Resolution
The maximum number of pixels that can be
displayed horizontally and vertically.

Source
The device, such as a computer or DVD player,
connected to the Spyder for display.

Stereoscopic
The creation of a 3D or stereoscopic display is
based on the principle that a person’s eyes see
two different viewpoints. These two distinct
viewpoints are then projected onto a screen so
that each eye sees the proper perspective; the
left eye sees only the left-eye viewpoint, and the
right eye sees only the right-eye viewpoint. The
brain then reads both viewpoints simultaneously
to produce a single image with the depth
necessary to make it appear three dimensional.
There are two ways to present 3D content, active
stereoscopic (on page 40) or passive stereoscopic
(on page 41) displays.
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