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Every effort has been made to ensure the information in this document is 
accurate and reliable; however, due to constant research, the information in 
this document is subject to change without notice.

COPYRIGHT NOTICE

© 2006-2010 Christie Digital Systems USA, Inc. - All rights reserved.

This document contains proprietary information of Christie Digital Systems 
USA, Inc., and may not be reproduced, stored in a retrieval system, 
transferred to other documents, disclosed to other manufacturers, or used for 
manufacturing or for any other purpose, in whole or in part, without prior 
written permission of Christie Digital Systems USA, Inc.

Christie Digital Systems USA, Inc., reserves the right to make changes to 
specifications at any time without notice. The information furnished in this 
publication was believed to be accurate and reliable. Christie Digital 
Systems USA, Inc. makes no warranty of any kind with regard to this 
material, including, but not limited to, implied warranties of fitness for a 
particular purpose. Christie Digital Systems USA, Inc. shall not be liable for 
errors contained herein or for incidental or consequential damages in 
connection with the performance or use of this material.

GRAPHIC ILLUSTRATIONS

All drawings, including system layout, hardware devices, controls and 
indicators, screens, and maintenance drawings are provided to enhance 
understanding of the accompanying text. These graphics are representations 
only; they are not necessarily drawn to scale and may not represent parts of 
your specific machine.

TRADEMARKS

TWIST is a trademark of Christie Digital Systems USA, Inc. All other 
trademarks used in this manual are the property of their respective owners.



SOFTWARE LICENSING AGREEMENT

This Software License Agreement (the “Agreement”) is a legal Agreement 
between the end user, either, an individual or business entity (“Licensee”) 
and Christie Digital Systems USA, Inc. (“Christie” or “Licensor”) for the 
software known commercially as TWIST 1.6 (“Software”). If Licensee does 
not accept the terms of this Agreement, Licensee shall return the Christie 
product and the Software to the vendor.

LICENSE AND RESTRICTIONS

Ownership of Software: Christie and its third party suppliers retain title and 
ownership of all rights, including copyright and all other intellectual 
property rights, in and to the Software and accompanying written materials 
(the “Documentation”), and all copies thereof, regardless of form or media. 
This License is not a sale of any rights in or to the Software or the 
Documentation or any copy thereof. Licensee acquires no right whatsoever 
to the Software or the Documentation except the right to use the Software 
and the Documentation in accordance with the terms of this License. 

Third Party Licenses: Licensee acknowledges that the Software may 
utilize software and other materials provided by third parties. Such third 
parties may enforce the provisions of this License to the extent such third 
party software and other materials are used by Licensee. Any limitation of 
liabilities in this License also apply to such third party suppliers and the third 
party software and other materials provided by them. Such limitation of 
liabilities, apply to the Software as a whole and are not cumulative.

Grant of License: The Licensor grants to Licensee, a non exclusive and 
non-transferable right to use for personal or internal business purposes, the 
executable version of the Software and the Documentation, as long as 
Licensee complies with the terms and conditions of this License. Licensor 
reserves all rights not expressly granted to Licensee.

Copy Restrictions: Licensee may keep one copy of the Software solely for 
backup or archival purposes. Unauthorized copying or distribution of the 
Software, including Software which has been modified, merged, or included 
with other software or of the Documentation is expressly prohibited unless 
agreed to in writing by Christie. Licensee must reproduce and include the 
copyright notice on any backup copy of the Software and Documentation. 
Licensee may not remove any proprietary rights or copyright notice or 
identification which indicates the ownership by Christie of the Software or 
the Documentation. 
TWIST 1.6 User Manual i
020-100143-07  Rev. 1  (06-2010)



Use Restrictions: Licensee shall not (a) modify, adapt, decompile, 
disassemble reverse engineer, or otherwise attempt to derive the source code 
for the Software, or create derivative works based on the Software or the 
Documentation; (b) assign this License or redistribute, encumber, sell, 
transfer, lease, or grant a sublicense of the Software or the licenses granted 
herein or otherwise transfer rights to the Software to any person or entity 
except as and when authorized by the Licensor in writing; (c) directly or 
indirectly, export or transmit the Software, either alone or bundled with other 
software, to any country to which such export or transmission is restricted by 
any applicable laws without the appropriate prior written consent of the 
applicable government entity or department. Licensee will make reasonable 
efforts to prevent any unauthorized use of the Software or Documentation by 
third parties and will advise Licensee's employees of the restrictions upon 
use restrictions herein.

MAINTENANCE AND SUPPORT

Term of Maintenance and Support: The Licensor shall provide 
maintenance and support services related to the Software (“Support 
Services”) for a period of 90 days from the date of receipt of the Software. 
Support Services are governed by the Licensor's policies and programs 
described in materials provided by the Licensor. Any supplemental software 
code provided to the Licensee as part of the Support Services shall be 
considered part of the Software and subject to the terms and conditions of 
this Software License Agreement.

WARRANTY AND LIMITATION OF LIABILITY

Product Warranties: The Licensor warrants that the Software will perform 
substantially in accordance with the accompanying written materials for a 
period of 90 days from the date of receipt of the Software. This warranty is 
void if the Licensee or any third party changes or modifies the Software. The 
liability of this Licensor under this section is limited to the correction of any 
error or malfunction and shall not include liability for loss of data, loss of 
computer time, any direct damages or any indirect or consequential 
damages. This warranty only extends to those failures communicated to the 
Licensor in writing within 90 days of the receipt of the Christie Digital 
product. The Licensor does not warrant that the Software is free from any 
minor defects or that it will operate uninterrupted. The Licensor does not 
make any other warranties, either express or implied, including, but not 
limited to, implied warranties of merchantability, fitness for a particular 
purpose, title and non-infringement, with regard to the Software. Some 
jurisdictions do not allow limitations or duration of an implied warranty, so 
the above limitation may not apply to you.
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Licensee's Remedy: The Licensor's entire liability and the Licensee's 
exclusive remedy shall be repair or replacement of the Software that does 
not meet the Warranty. Any replacement Software will be warranted for the 
remainder of the original warranty period or thirty (days), whichever is 
longer.

Exclusions and Limitation of Liability: In no event shall the Licensor be 
liable for any loss of data or profits or special, incidental, indirect or 
consequential damages, (including, without limitation, damages for loss of 
business profits, business interruption, loss of business information, or any 
other pecuniary loss) arising out of or in connection with the use of or 
inability to use the Software, even if the Licensor has been advised of the 
possibility of such damages. In no event will the Licensor be liable for any 
damages caused by the Licensee's failure to meet Licensee's responsibilities, 
which responsibilities include without limitation, the provision of properly 
functioning and compatible hardware, operating systems, or applications 
software, or arising out of incomplete or inaccurate information provided to 
the Licensor. In any case, the Licensor's entire liability under this Agreement 
shall be limited to CDN$1,000.

TERMINATION AND DEFAULT

Termination: The Licensor may terminate this Agreement if the Licensee 
breaches or is in default of any obligation. Should this Agreement be 
terminated for any reason, the Licensee agrees to immediately cease using 
the Software and to return to the Licensor all copies of the Software. The 
Licensee's obligation under this section shall survive the termination of the 
Agreement.

GENERAL

Notices: Unless otherwise set forth in this Agreement, all notices, demands 
or other communications to the Licensor hereunder shall be in writing 
(including telecopy) and shall be deemed to have been duly given if 
delivered during normal business hours by hand, Federal Express, United 
Parcel Service or other reputable overnight commercial delivery service, by 
telecopy, confirmation of receipt received, or by mail with return receipt 
requested, addressed as follows:

Christie Digital Systems USA, Inc.
c/oChristie Digital Systems Canada, Inc.
Legal Department
809 Wellington Street North
Kitchener, Ontario
N2G 4Y7
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Severability: If any provision of this Agreement is held to be invalid, such 
invalidity shall not affect the other provisions of this Agreement.

Waiver: No waiver by the Licensor of any particular default or omission 
committed by the Licensee shall affect or impair the right of the Licensor in 
respect of any subsequent default or omission of the same or a different kind. 
No delay or failure by the Licensor to exercise any rights in connection with 
any default or omission committed by the Licensee shall affect or impair the 
Licensor's rights in respect of that particular default or omission or any 
subsequent default or omission of the same or different kind. In any event, 
time shall continue to be of the essence without the necessity of specific 
reinstatement.

Governing Law: This Agreement shall be governed by and interpreted in 
accordance with the laws of the Province of Ontario and the federal laws of 
Canada applicable therein. The Parties hereby will attorn to the non-
exclusive jurisdiction of the Courts of the Province of Ontario.
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1 Introduction

1.1 Document Contents

This guide includes the following sections:

• Section 1 Introduction: This section outlines document contents and 
conventions.

• Section 2 Installation and Setup: This section describes the system 
characteristics required to run the TWIST Software, the installation 
requirements and how to properly setup the projectors. 

• Section 3 About TWIST™ Software: This section provides an 
overview of the software.

• Section 4 Managing Settings and Files: This section describes how to 
work with TWIST configuration files.

• Section 5 Working with Projectors: This section describes how to 
work with the projector and the TWIST Software.

• Section 6 Working with the Main Interface: This section describes 
how to shape warps, blends and masks by moving points and shaping 
curves.

• Section 7 Warping: This section describes how to control warps.

• Section 8 Blending: This section describes how to create blend regions 
for blended images.

• Section 9 Masking: This section describes how to mask extraneous 
information.

• Section 10 Brightness Uniformity: This section describes how to work 
with the brightness uniformity feature.

• APPENDIX A Fine Tuning Warps: This section describes how to fine 
tune warping using the projector's anti-aliasing functions.
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Section 1: Introduction
1.2 Document Conventions

• KEYPAD COMMANDS/PC KEYSTROKES E.G., POWER, ENTER, CHANNEL

• Content Reference e.g,. Section 5 - Troubleshooting

• Document Reference e.g., Using 3D in Mirage

• Figure/Table References e.g., Figure 2.1, Table 4.3

• Software Menus/Options e.g., Show Warp, Control Point Properties

• On screen Messages e.g., No Signal
• OPERATIONAL STATES E.G., POWER, ON, OFF

1.3 Related Documents

The information included in this user manual is also included in the TWIST 
on-line help.

For more information about your projector, see the projector manual.
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2 Installation and Setup

The following section outlines the requirements needed to run the TWIST™ 
software, Version 1.6. It also includes the setup procedures required to 
control projectors with the software.

2.1 Requirements

2.1.1 Recommended System

• PC running an Intel or 100% compatible processor

• Windows XP SP1 or later, Windows Vista, Windows 7

• 200 MB of free disk space

• 512 MB of RAM (1 GB recommended)

• 1 available serial port or 1 available Ethernet port

• 1 available USB port (TWIST Pro)

NOTE: M-Series and StIM projectors require an Ethernet connection.

2.1.2 Projector Requirements

TWIST depends on the correct Projector firmware:

• M-Series projectors tested with firmware 2.0 (1.5.0 minimum)

NOTE: M-Series projectors with firmware 1.7 or later require Twist 
1.5.4 or later.

NOTE: M-Series projectors with firmware 1.8 or later require Twist 
1.5.5 or later.

• StIM projectors tested with firmware 1.3 (1.0 minimum)

NOTE: StIM projectors require Twist 1.5.5 or later.

• All other TWIST-enhanced projectors tested with:

• 1.6f (main projector) - (1.2f minimum)
• 2.0 (warping firmware)
• 3.5 (XPort firmware)
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Section 2: Installation and Setup
NOTES: 1) Later versions of the firmware will likely work with no issue. 
Earlier versions should not be used. 2. Press Menu, and select 6 (Status) to 
verify firmware versions (lower-right corner of the Status window). 

2.1.3 Connection Requirements

Serial Connections

1 serial cable per projector. This is not available for M-Series and StIM 
projectors.

Figure 2-1 Serial Connection

Ethernet Connections

• 1 network hub

• 1 Ethernet cable to connect the PC to the network hub

• 1 Ethernet cable per projector

Figure 2-2 Ethernet Connection

2.2 TWIST Software Installation

IMPORTANT! In order to install TWIST you must have administrator 
privileges.

The installation wizard walks you through the installation. 

1. Insert the installation CD into the CD drive. The installation starts 
automatically and the installation welcome wizard dialog appears. If the 
installation does not start automatically, select Start > Run. In the Run 
dialog type: D:\setup.exe, substitute D: with your CD-ROM drive letter.

2. Click Next. 
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Section 2: Installation and Setup
3. Enter the appropriate information in the Setup dialog window and click 
Next. 

4. Click Next to accept the default location where the software will be 
stored. This will display the Start Copying Files dialog window.

5. Click Next to install the software. Once the system has been updated a 
dialog window appears notifying users that the installation was 
successful. 

6. Click Finish.

NOTE: TWIST automatically installs the following required software: 
Bonjour, Microsoft Visual C++ 2008 Redistributable, and Java Runtime 
Environment.

2.2.1 Uninstalling TWIST

To use the Installation wizard to uninstall TWIST:

1. Insert the installation CD to access the installation wizard welcome 
screen.

2. If the installation does not start automatically, select Start>Run.

3. In the Run dialog type: D:\AutoRun.exe, substitute D: with the 
specific CD-ROM/DVD-ROM drive letter.

4. Select the Remove option, then click Next.

5. Click Next again to begin the uninstall process.

6. Click Finish to exit.

NOTE: The supporting software may be used by other programs and 
therefore is not uninstalled automatically by the wizard. To uninstall these 
programs, access the system’s Add or Remove Programs control.

The supporting software includes: Bonjour, Microsoft Visual C++ 2008 
Redistributable, and Java Runtime Environment.

2.3 Setting Up the Projectors

NOTE: Each projector must have a unique projector ID.

2.3.1 Connect Projector(s) - Serial

1. Connect a standard serial cable from COM1 on your computer to the 
“RS-232 In” connector on the back of the projector.

2. For multiple projectors, connect the “RS-232 Out” from the previous 
projector to the “RS-232 In” on the next projector.
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Section 2: Installation and Setup
2.3.2 Connect Projector(s) - Ethernet

1. Connect an Ethernet cable from the PC to the network hub. 

2. Connect an Ethernet cable from the projector to the network hub.

3. Repeat Step 2 for each additional projector (“Ethernet Connections” on 
page 2).

2.3.3 Configure Projector ID

Access the projector menu either via the control buttons on the projector or 
the remote control to display the menus on the projected screen. All menu 
options are numbered. You can select menu items either by selecting the 
option using the UP and DOWN arrow buttons and then pressing ENTER, or by 
pressing the option number on the number pad.

1. On the projector or projector remote, press the MENU button to access 
the main menu.

2. Select 4 CONFIGURATION.

3. Select 7 COMMUNICATION.

4. Select 3 PROJECTOR.

5. Specify a unique identification number.

6. Press the MENU button to exit the projector's menu structure.

NOTE: Each projector that uses a serial connection must have a unique 
identification number. If the TWIST software detects two projectors with 
the same ID, both projectors will be flagged with an error status and the 
software will not attempt to communicate with either projector. 

2.4 USB License Key

The TWIST software requires a USB license key to run the Pro version. The 
software will run if the USB license key is not plugged into a USB port; 
however, only the basic software features will be available. 
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Section 2: Installation and Setup
2.5 Starting Software

The TWIST software will only run if there is a TWIST enabled projector 
connected to the computer. 

1. To start the software, click 
Start>Programs>Christie>Twist>Twist 1.6. The welcome dialog 
window appears.

Figure 2-3 Welcome Screen

2. Click New to create a new configuration file. For more information, see 
4.1 Create a New Configuration File. 

Or:

3. Click Open to open an existing configuration file. For more 
information, refer 4.4 Open an Existing Configuration File.
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3 About TWIST™ Software

This section provides a brief overview of the key software features.

3.1 Effects

TWIST software provides easy access to the digital image functionality of 
any TWIST-enhanced projector. It allows you to combine projected images 
from multiple projectors into a single seamless image and adjust it to fit the 
screen.

3.1.1 Warps 

Warps fit the image to a variety of screen shapes easily, from keystone 
corrections on flat screens to spherical or cylindrical curved screens to 
arbitrary screen shapes. For information about creating and managing warps, 
see 7 Warping.

Figure 3-1 Managing warp definitions
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Section 3: About TWIST™ Software
3.1.2 Blends

Digital blend definitions allow images from multiple projectors to be 
overlapped such that a single seamless image is achieved. For information 
about creating and managing blends, see 8 Blending

Figure 3-2 Managing blend definitions
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Section 3: About TWIST™ Software
3.1.3 Masking

Sometimes fitting the image to a specified screen shape without distorting 
the geometry of the image affects the shape of the image. You can mask out 
the extraneous information at the edge of the image. The default box on the 
Masking Tab's work area is the full potential projection, not the warped 
projection, which will typically lie within the boundaries of the default 
projection. For details, see 9 Masking.

Figure 3-3 Managing mask definitions

3.1.4 Brightness Uniformity

This feature enables a user to manipulate brightness uniformity in instances 
where projectors are placed in positions where the direction of projection 
differs greatly from the normal surface of the screen. In these type of 
installations, it results in image keystoning and brightness uniformity 
differences across the image, and in some instances inconsistencies in the 
native size of the adjacent channels. To compensate for these inconsistencies 
the brightness uniformity feature can be used to define a regular array of 
control points at which the brightness value can be specified. For details, see 
10 Brightness Uniformity.
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Section 3: About TWIST™ Software
NOTE: Brightness uniformity is not available when running the basic 
version of TWIST Software.

Figure 3-4 Managing brightness uniformity definitions

3.2 Interactive and Iterative

Warping, blending, masking, and brightness uniformity functions in the 
TWIST Software are interactive. You can easily test changes by sending the 
settings to the projectors. 

You can save warps, blends, masks, and brightness uniformity settings to the 
projectors, and to configuration files for future tweaking. Configuration files 
save the projector names, warps, blends, masks, brightness uniformity 
settings and memory locations where the settings are stored on the 
projectors.

You can use existing configuration files as a basis for new configuration 
files. For more information, see 4 Managing Settings and Files.

3.3 Virtual Remote

A virtual remote (on your computer) functions the same as the physical 
remote on the projectors. The virtual Remote commands will operate on all 
selected projectors.
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Section 3: About TWIST™ Software
The virtual remote is accessed from the Tools>Virtual Remote menu.

Figure 3-5 Virtual remote

3.4 Best Practices for Working with TWIST Software

• Create a configuration file. For more information, see Welcome Dialog.

• Rename the projectors to indicate their positions in the display. 
Renaming the projectors makes it easier to work when you're zoomed in 
on individual projectors.

• Name the configuration files to identify the specific configuration or 
use.

• Follow the GUI layout when setting up the configuration file; create the 
warp first, match the blend edges to the warped image, mask out 
extraneous information, and adjust brightness uniformity.

• Save the configuration file periodically as you work. Save to the 
projector when you are satisfied with the warp definition.
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4 Managing Settings and Files

The software is designed to work with configuration files. All warping, 
blending, masking, and brightness uniformity information is saved in the 
configuration files. When you start the software, you have the option of 
opening an existing configuration or creating a new one. 

Figure 4-1 Welcome Dialog

4.1 Create a New Configuration File

You can create a new configuration file at any time using the File>New 
option. The decisions you make when creating a new configuration file 
determine default settings and functionality.

1. On the File menu, click New to display the Communication Setup 
dialog window.

Figure 4-2 Communication Setup Dialog

2. Specify how the projectors are connected and specify the port used.

Serial – One projector is connected to the computer and each additional 
projector is daisy-chained to the previous projector.
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When connected serially, the TWIST Software requires that each 
projector have a unique ID and will not communicate with projectors 
with duplicate IDs. Duplicate projector IDs indicate one of two 
problems. 1) Two or more projectors have the same ID. In this case you 
will need to access the projectors and change their IDs so that each is 
unique. If you correct projector IDs after you create your configuration 
file, you will need to change the projector ID in the file to match the 
new IDs. 2) The configuration file includes 2 or more projectors with 
the same ID, but all the attached projectors have unique IDs. This 
problem can result from importing configuration information. Select the 
affected projector, click Edit>Properties and correct the projector's ID. 

NOTE: M-Series & StIM Projectors cannot be controlled in Twist via a 
serial connection.

Ethernet – Each projector is connected to an Ethernet hub that is connected 
to the computer. The TWIST Software searches for all connected 
projectors that use the specified port. It does not require an IP address.

3. Click Next to detect all the projectors that are properly connected.

The Projector Selection dialog appears.

Figure 4-3 Projector Selection Dialog

4. To sort the list, click the column header.

5. Select the projectors you want to work with. Projectors flagged with No 
Warp Board cannot be selected for inclusion in the configuration.

NOTE: When running the basic version of the TWIST Software the user 
is restricted to 6 projectors.
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6. Click Next. The Display Setup dialog appears.

Figure 4-4 Display Setup Dialog

7. Specify the settings on the Display Setup dialog. For more information, 
see 4.2 Display Setup Dialog. 

8. Click Finish to apply the changes and advance to the main TWIST 
window.

4.2 Display Setup Dialog

In the Display Setup dialog box you identify initialization information for 
the new projector configuration. These settings apply to all the projectors 
selected for the current configuration. You can override the settings for any 
projector at any time. For more information about changing settings, see 
4.3 Edit Projector Information.

Figure 4-5 Display Setup Dialog
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Projector Settings

Name Prefix – Specifies the prefix used for the default projector labels that 
are applied when you initialize a new configuration. The default projector 
labels are comprised of the prefix and the projector ID. Projectors are 
labeled and arranged serially based on the projector ID.

Layout – Identifies the projector array. Projectors are positioned in the array 
serially, based on the projector ID. This is used to determine the initial 
positions and blends of the projectors in the workspace. You can change 
the configuration after initialization by dragging projectors into different 
positions in the Layout view. For more information, see 5.4 Arrange 
Projector Layout.

Warp Settings

Name Prefix – Specifies the prefix used to build the default warp names 
for this configuration. After initialization, you can change the individual 
warp names. 

Memory Location – Identifies the flash memory location on the projector 
to which warp settings can be saved. Each projector can store up to 5 
custom warp definitions. You can select any number from 1 to 5. These 
correspond to the custom warps user1 to user5 on the Projector menu. M-
Series and StIM projectors can store up to 16 custom warp definitions. 

Resolution – Indicates the number of vertical and horizontal lines in the 
warp grid. Larger numbers allow for finer control of the warp field, but 
require more individual adjustments and control.

NOTE: When running the basic version of the TWIST software, 
resolution is restricted to a maximum configuration of 10x10. The 
TWIST Pro Software offers a maximum configuration of 31×31.

Blend Settings

Name Prefix – Specifies the prefix used to build the default blend names 
for this configuration. After initialization, you can change the individual 
blend names. 

Memory Location (Blend) – Identifies the memory location on the 
projector to which blend settings can be saved. This field is read-only and 
is selected via the Warp Settings Memory Location selection. Each 
projector can store up to 5 custom blend definitions. These correspond to 
the custom blends user1 to user5 on the Projector menu. M-Series and 
StIM projectors can store up to 16 custom blend definitions. 
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Blend Calculation (Automatic) – Enables automatic calculation of blend 
regions. Automatic blend calculation enables the overlapping blend 
regions of adjacent projectors and adjusts the calculated blend region as 
you adjust the warp. You can turn automatic calculation for selected 
projectors OFF or ON once the configuration file is initialized.

Horizontal Overlap – Identifies the default width of the blend region as a 
percentage of the projected area.

Vertical Overlap – Identifies the default height of the blend region as a 
percentage of the projected area.

Mask Settings

Name Prefix – Specifies the prefix used to build the default mask names 
for this configuration. After initialization, you can change the individual 
mask names. 

Brightness Uniformity Settings

Global Intensity – The global intensity value enables users to have finer 
control of the projector brightness, as opposed to controlling brightness 
through the lamp power. This feature changes the brightness intensity 
globally throughout the entire image versus changing brightness via lamp 
power, which changes brightness intensity to a fixed area of the image. 
Image contrast is compromised when controlling projector brightness 
through the global intensity feature.

Name Prefix – Specifies the prefix used to build the default brightness 
uniformity names for this configuration. After initialization, you can 
change the individual brightness uniformity names. 

Memory Location – This field is read-only and is selected via the Warp 
Settings Memory Location selection. Identifies the flash memory location 
on the projector to which brightness uniformity settings are saved. Each 
projector can store up to 5 custom brightness uniformity definitions. These 
correspond to the custom brightness uniformity user1 to user5 on the 
Projector menu. M-Series and StIM projectors can store up to 16 custom 
brightness uniformity definitions.

NOTE: See 4.7 Save Effects to the Projector to see how these settings are 
related once they are saved on the projector.
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4.3 Edit Projector Information

You can change projector information after the configuration has been 
initialized though the Properties menu. The settings in the Properties dialog 
window apply to the selected projector only. 

1. In the preview panel select the projector you want to make changes to.

2. On the Edit menu, click Properties. The Properties dialog for the 
selected projector appears (Figure 4-6).

3. Adjust the settings, as required. For information about the individual 
options, see 4.3.1 Properties Dialog/Add a New Projector.

NOTE: You can also edit IDs and projector names quickly by typing directly 
in the summary table at the bottom of the preview panel.

4.3.1 Properties Dialog/Add a New Projector

The Properties dialog window (Figure 4-6) allows you to change names and 
storage locations. The settings in the Properties dialog apply to the selected 
projector only. 

Properties Dialog - General Tab

Figure 4-6 Properties Dialog, General tab

Projector

Projector Name – The default display name is a combination of the 
Projector Settings - Name Prefix specified when you created the 
configuration file and a serial number. When you add a projector to an 
existing configuration, only the prefix is prompted.
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Projector ID – Identifies the projector that will receive the configuration 
information. The warping software currently does not work in broadcast 
mode; an individual command can be issued only to a single projector at a 
time.

Warp Continuity Mode – When checked enables additional validation 
when working with warps for M-Series and StIM projectors. The effect is 
similar to Spring Mode. Moving points which create too large a distortion 
causes neighboring points to move to meet hardware requirements. This 
option is enabled by default. It does not affect non-M-Series projectors.

Orientation – Indicates the projector orientation in the Twist workspace. 
Twist can work with projectors that are set up in portrait mode. Select the 
orientation for the projector in the layout to match the  orientation of the 
physical projector.

• Normal is the default landscape mode.
• Portrait CCW indicates that the projector is rotated 90 degrees counter 

clockwise.
• Portrait CW indicates that the projectors is rotated 90 degrees clock-

wise.

Figure 4-7 Projectors: Portrait Mode and Landscape Mode

Warp

Warp Name – Identifies the warp settings associated with the specified 
Memory Location for this configuration. The default name is a 
combination of the Warp Settings - Name Prefix specified when you 
created the configuration file and a serial number. When a warp is saved to 
the projector, the name is added to the list of warps available on the 
projector. You can change the name to any alphanumeric string. Changes 
made in the current configuration do not appear on the projector until the 
next time you save the warp to the projector. When you add a projector to 
an existing configuration, only the prefix is prompted.
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Memory Location – Identifies the flash memory location on the projector 
to which warp settings can be saved. Each projector can store up to 5 
custom warp definitions. You can select any number from 1 to 5. These 
correspond to the custom warps user1 to user5 on the Projector menu. 
When you add a projector to an existing configuration, the default value 
specified during initialization is used. M-Series and StIM projectors can 
store up to 16 custom warp definitions.

Resolution – Indicates the number of vertical and horizontal lines in the 
warp grid. Larger numbers allow for finer control of the warp field, but 
require more individual adjustments and control. When you add a 
projector to an existing configuration, the default value specified during 
initialization is used.

Blend

Blend Name – Identifies the blend settings associated with the specified 
Memory Location. The default name is a combination of the Blend 
Settings - Name Prefix specified when you created the configuration file 
and a serial number. When a blend is saved to the projector, the name is 
added to the list of available blends. You can change the name to any 
alphanumeric string. Changes made in the current configuration do not 
appear on the projector until the next time you save the blend to the 
projector. When you add a projector to an existing configuration, only the 
prefix is prompted.

Memory Location (Blend) – Identifies the memory location on the 
projector to which blend settings can be saved. Each projector can store up 
to 5 custom blend definitions. You can select a number from 1 to 5. These 
correspond to the custom blends user1 to user5 on the Projector menu. M-
Series and StIM projectors can store up to 16 custom blend definitions. 
When you add a projector to an existing configuration, the default value 
specified during initialization is used. 

Brightness Uniformity

Global Intensity – The global intensity value enables users to have finer 
control of the projector brightness, as opposed to controlling brightness 
through the lamp power. This feature changes the brightness intensity 
globally throughout the entire image versus changing brightness via lamp 
power, which changes brightness intensity to a fixed area of the image. 
Image contrast is compromised when controlling projector brightness 
through the global intensity feature.
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Brightness Uniformity Name – Identifies the brightness uniformity 
settings associated with the specified Memory Location. The default 
name is a combination of the Brightness Uniformity Settings - Name 
Prefix specified when you created the configuration file and a serial 
number. When brightness uniformity is saved to the projector, the name is 
added to the list of available uniformities. You can change the name to any 
alphanumeric string. Changes made in the current configuration do not 
appear on the projector until the next time you save brightness uniformity 
to the projector. When you add a projector to an existing configuration, 
only the prefix is prompted. 

Memory Location (Brightness Uniformity) – Identifies the memory 
location on the projector to which brightness uniformity settings can be 
saved. Each projector can store up to 5 custom brightness uniformity 
definitions. You can select a number from 1 to 5. These correspond to the 
custom brightness uniformities user1 to user5 on the Projector menu. M-
Series and StIM projectors can store up to 16 custom brightness 
uniformity definitions.When you add a projector to an existing configura-
tion, the default value specified during initialization is used. 

Properties Dialog - Communication Tab

Figure 4-8 Properties/Communication tab

Communication Type

Identifies the method used to connect the projector to the computer. 

NOTE: You can have both Serial and Ethernet connections.

Serial – One projector is connected to the computer and each additional 
projector is daisy-chained to the previous projector.
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Ethernet – Each projector is connected to an Ethernet hub that is connected 
to the computer. When you add a projector to an existing configuration, 
indicate how the new projector is connected. 

Serial

Serial Port – Identifies the communication port used to communicate with 
serially connected projectors. The default port is COM1.

Baud Rate – Identifies the baud rate used to communicate with serially 
connected projectors. The default baud rate is 115200.

Ethernet

IP Address – Identifies the Ethernet-connected projector IP address. When 
you add an Ethernet projector, or when you change the communication 
type for a projector to Ethernet, you must specify the IP address.

Port – Identifies the port the Ethernet-connected projector will use to 
communicate. The default port is 3002. The port specified here must 
match the port specified on the projector. For M-Series and StIM 
projectors, leave blank in order to find all available projectors.

4.4 Open an Existing Configuration File

When you open a projector configuration file, the projector automatically 
switches to the warp and blend memory locations specified in the configura-
tion file. The TWIST Software displays the information from the configura-
tion file. The stored configuration and the configuration file may not match.

1. On the File menu, click Open.

2. Browse to the folder where your configuration files are stored. 

3. Select the file to open, and click OK.

NOTE: If you have defined multiple warps or blends, the first is displayed. 
You can select a different warp or blend to work with by clicking on the 
appropriate warp or blend settings for a specific projector in the project 
summary area of the interface and by clicking the desired selection. The 
mask is linked to and displayed with the warp. For M-Series and StIM 
projectors, the mask and brightness uniformity is linked to and displayed 
with the blend.
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4.5 Save Effects to a Configuration File

You can save warping, blending, masking and brightness uniformity settings 
to a configuration file to save your work in progress and to create a backup 
for final settings you will send to the projector.

1. On the File menu click Save. If you have not saved the file before, you 
will need to enter a name for the configuration file.

2. Click Save.

All the configuration settings, including multiple warps, blends, masks and 
brightness uniformity are saved to the specified file.

4.6 Auto Save

TWIST software automatically saves the current configuration to a backup 
file every 60 seconds. The backup file is located in the user home directory, 
for example C:\Documents and Settings\<username>\TwistAutoSave.twist.

You can enable the TWIST software to automatically update named .twist 
files. To enable automatic saving to named files, click the Tools menu and 
check the Auto Save option. Once the current configuration has been saved 
to a named file, automatic saves are applied to the current filename.

4.7 Save Effects to the Projector

The following table summarizes how TWIST data is stored and accessed at a 
given memory location on the projector.

Some effects share memory locations on the projector. See the above table to 
determine which information shares a memory location for your projector. 
Although you can adjust and save one or more of the effects at any time, 
effects saved to the same memory location become linked. Ensure you do 
not inadvertently save mismatched warps, blends, masks, and brightness 
uniformities. 

Table 4.1 TWIST information storage locations on projectors

TWIST Effect
M-series and 

StIM Projectors

All Other TWIST-
enhanced Christie 

Projectors

Warps Independent Shared

Blends Shared Independent

Masks Shared Shared

Brightness Uniformity Shared Independent
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When selecting an effect to display on the projector, linked effects also 
display. For example, when you select a blend on an M-series projector, the 
linked mask and brightness uniformity display, too.

To send the currently displayed warp, blend, mask or brightness uniformity, 
click Save from the left panel. The status light in the lower-right corner will 
blink while the system sends the settings to the projector.

NOTES: 1) While working on your settings, you can send changes to display 
via the projector automatically as you make the changes. For more 
information, see 5 Working with Projectors. 2) Depending on the amount of 
information being sent, the send process can take several seconds.

4.8 Import One File into Another

1. Click File>Import.

2. Browse to the .twist file you want to import.

3. Select the file and click Open. All projector configuration information 
is copied into the current file. The TWIST Software marks duplicate 
projectors in the projector summary table. 

4. The TWIST Software cannot communicate with duplicate projectors, 
you must resolve duplicate projectors before you can send information 
to them.

5. Use Layout Mode to re-arrange the projectors. For more information, 
see 5.4 Arrange Projector Layout.

6. Click File>Save to save your changes.

4.9 Download Settings From The Projector

You can download warp, blend, mask, and brightness uniformity data from a 
projector into an existing Twist configuration. For example, use this feature 
when you want to recover warping and blending data saved on a projector 
for which a valid TWIST configuration file no longer exists. The warping 
and blending data on the projector must be valid. 

NOTE: This feature is available on M-Series and StIM projectors with 
firmware version 1.5.1 or higher.
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1. In the Projector layout panel, select a projector to download data from.

2. Click File>Download. The Download From Projector dialog appears.

Figure 4-9 Download From Projector

3. Click the Warps tab. 

4. For each warp you want to download, check the Select column and 
specify a target memory location in the Save To column.

5. Click the Blends/Masks/Brightness Uniformities tab. 

6. For each data set you want to download, check the Select column and 
specify a target memory location in the Save To column.

7. Click the Download button.

8. Click Save to save the downloaded data in the current configuration.

NOTE: If you specify a target memory location that contains existing 
warps/blends/masks/brightness uniformities, the system will prompt you 
to confirm the download before overwriting existing data in the current 
Twist configuration.

NOTE: To reconstruct a multi-projector configuration, repeat this 
procedure for each projector in the configuration. 
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5 Working with Projectors

This section outlines how to work with projectors and the configuration files.

5.1 Select Projectors in the Current Configuration

You can select one or more projectors in the preview panel to which you can 
send or save updated settings. Click a projector to select it. 

NOTE: To select multiple projectors, press and hold the CTRL key and click 
each desired projector. Multiple selected projectors are outlined in yellow.

Figure 5-1 Multiple Selected Projectors

5.2 Zoom In/Out

The TWIST™ Software attempts to fit projector grids into the preview 
window, resizing the grids where necessary. 

• To zoom in and center a particular projector, double-click the projector 
from the list. 
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• To zoom out, roll the mouse wheel towards you (as in scrolling down) 
or click the Zoom Out toolbar button  to activate the zoom out 
tool. Subsequent clicks in the preview window zoom out the display.

• To zoom in roll the mouse wheel away from you (as in scrolling up) or 
click the Zoom In toolbar button  to activate the zoom in tool. 
Subsequent clicks in the preview window zoom in the display.

5.3 Add a Projector to the Configuration

You can add a projector after you have initialized a configuration, or even 
after you have worked with the settings. Before you can add a projector get 
the following information:

• Projector ID

• COM port, for projectors that are serially connected

• Ethernet port, for projectors that are not M-series or StIM projectors. 
For M-series and StIM projectors, the Ethernet port can remain blank.

NOTE: To get the IP Address and Port, press Menu on the Projector, select 4 
Configuration, 7 Communications and 5 Ethernet Settings.

1. On the preview panel, right-click to open the context menu.

2. Click Add Projector(s).

3. The Communication Setup screen appears. Specify how the projectors 
are connected and specify the port used.

Figure 5-2 Communication Setup

4. Click Next to continue.

5. The new projector(s) is added in the top-left corner of the preview 
panel. 

6. Use View>Layout to re-arrange the projectors. For more information, 
see 5.4 Arrange Projector Layout.
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5.4 Arrange Projector Layout

1. Click the Toggle Layout Mode button  from the main toolbar. The 
preview panel will lose focus.

2. Click to select a projector and drag with the mouse to move it to a 
different position.

3. If the physical projectors are set up in portrait mode, right-click each 
projector in the layout and select the matching Orientation option.

4. Click the Toggle Layout Mode button again to return to EDIT mode.

5.5 Remove a Projector from the Configuration

1. On the preview panel, click to select a projector.

2. Click Projector>Delete Projector(s). 

5.6 Previewing Data on the Projector

The Warps, Blends, Masks, and Brightness Uniformity tabs each allow you 
to preview your working changes to the projector without saving them to a 
file or projector location.

• To preview only the changes of the current tab, click the Preview button. 

• To preview the changes on all tabs for the current projector at once, 
click Projector>Preview All.

5.7 Automatically Previewing Changes on the Projector 

The TWIST Software can be setup to automatically preview changes to the 
projector as you work. Enabling the Auto Update setting applies to all the 
projectors. It updates the current warp, blend, mask or brightness uniformity 
as you work.

On the Tools menu click Auto Update to enable or disable this functional-
ity. Auto Update can result in delays since the software sends information to 
the projector every time you move a point.

5.8 Overriding a Warp from a Projector

To remove an unwanted warp from a memory location on the projector using 
the TWIST Software, replace the warp with another warp or with a default 
grid. For information about adding or deleting a warp from the current 
configuration, see 7.3.5 Add a Warp and 7.3.7 Delete a Warp. For 
information about adding a warp to a projector, see 4.7 Save Effects to the 
Projector.

1. Select the projector in the preview panel.
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2. Select a replacement warp to send from the drop-down list area in the 
projector summary area.

Figure 5-3 Memory Location

NOTE: To send a default grid, reset a warp or add a new warp to the 
selected projector. 

3. Click Edit>Properties and specify the memory location to replace.

4. Save the warp to the projector. For more information, see 4.7 Save 
Effects to the Projector.

5.9 Accessing Projector Functions with the Virtual Remote 

The virtual remote accesses all projector functions. It is identical to the 
physical remote.

1. Select the projector(s) you want to work with. For more information, see 
5.1 Select Projectors in the Current Configuration.

2. Click Tools>Virtual Remote.

3. Click the buttons on the virtual remote to select functions as you would 
on the projector remote. 

Figure 5-4 Virtual Remote
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6 Working with the Main Interface

This section includes information about shaping warps, blends and masks by 
moving points and shaping curves.

6.1 Shortcut Keys

You can use the following shortcuts to manipulate control points while the 
preview panel is in focus.

NOTE: Addition shortcut keys are indicated beside their menu commands. 
To view valid shortcut keys, access the menu. For example, click Edit to view 
editing commands and available shortcuts or right-click the preview window 
to view the context menu commands and available shortcuts.

NOTE: Undo and Redo are only available for some functions.

6.2 Display Guidelines

By default each work area associated with the warping, blending, masking 
and brightness uniformity tabs in the TWIST™ Software displays its own 

Table 6.1 Shortcuts

Key Control Action

Arrow Keys Move the selected point(s) up, down, left, right.

Shift-Arrow Keys Multi-select points.

CTRL-Arrow Keys Move the selected point(s) one pixel in the specified 
direction.

ALT-Arrow Keys Move the selected point(s) 10 pixels in the specified 
direction.

Enter Send the current tab’s data (warp, blend, mask, or 
brightness uniformity) to the projector.

CTRL-A Select all points for the selected projector.
TWIST 1.6 User Manual 6-1
020-100143-07  Rev. 1 (06-2010)



Section 6: Working with the Main Interface
control points and curves. To show the curves of the other tabs click the 
appropriate buttons (Figure 6-1). For example, to assist with shaping the 
blend to the warped screen users can show the warp grid in the blending 
workspace by clicking on the Show Warp button. 

• To show the warp on the Blending and Masking work areas, click the 
Show Warp button. 

• To show the blend on the Warping and Masking work ares, click the 
Show Blend button. 

• To show the mask on the Warping and Blending areas, click the Show 
Mask button.

• To show the gradient on the Warping and Blending areas, click the 
Show Gradient Image button. This is a the TWIST Pro feature only.

Figure 6-1 Controlling The Workspace
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6.3 Controlling Points

6.3.1 Move a Point

The TWIST Software requires that a minimum number of pixels be 
maintained between points, and between points and curves. A point can 
move within the bounds of its neighboring points and curves, but will stop 
short of touching them. The size of the buffer around a point or curve 
depends on the number of input pixels between the 2 neighboring points.

1. Click on a point and drag it to the desired position. Alternatively, press 
CTRL+ ‘Arrow keys’ to move the point 1 pixel, or press ALT + ‘Arrow 
keys’ to move the point 10 pixels at a time. 

Figure 6-2 Click and Drag a Point

Alternatively, you can specify coordinates in pixels for the point in the 
Offset fields (See 7.2 Warping Tab Fields and Controls). If the specified 
location is outside of the allowable area, the TWIST Software will place it as 
close as possible to the requested position. 

If advanced point placement is not used for blending and masking, an edge 
point can move only along the edge of the frame. Points can be added to 
shape a curve, but cannot be moved outside of the blend outline. The inside 
guide and the outside guide of a blending frame cannot cross. For more 
information, see 8.4.3 Advanced Point Placement.
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6.3.2 Move a Line of Points

You can move an entire line of points at the same time. The line will 
maintain its shape and stop when the first point reaches the buffer of another 
point or curve. Multiple points can be adjusted in the viewer using the mouse 
or keyboard (CTRL+arrow or ALT+arrow) controls. Position/Offset fields 
are disabled when multiple fields are selected.

1. To select a line of points, click anywhere on the line. The selected points 
turn red and the line green.

2. Click on the line and drag it to the new position.

Figure 6-3 Click and Drag a Line

6.3.3 Move a Group of Points

Multiple points can be adjusted in the viewer using the mouse or keyboard 
(CTRL+arrow or ALT+arrow) controls. Multiple points can only be adjusted 
in the viewer using the mouse or keyboard controls. Position/Offset fields 
are disabled when multiple fields are selected. To select all the points on the 
selected projector, press CTRL+A. 
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1. To select a group of points drag a square around the group of points 
using CTRL or ALT-arrow with the mouse or keyboard.

2. Once selected the points turn red. Click any of the highlighted points 
and drag the group to its new position. 

Figure 6-4 Click and drag a group

6.3.4 Add a Point

You can add individual control points to blend curves and mask curves. 
Adding points allows for finer adjustments in the specified area of the 
projection. 

NOTE: Individual points cannot be added to warp grid lines. To make finer 
adjustments to a warp, increase the warp grid's resolution. For more 
information, see 7.3.2 Change the Warping Grid Resolution.
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1. Position the Selection Tool on the line, right-click and select Add 
Point. 

Figure 6-5 Adding a Point

6.3.5 Remove a Point

Points that have been added to the blend or mask curves can be removed, but 
the original end points cannot. For more information, see 7.3.2 Change the 
Warping Grid Resolution. If you have selected multiple points, the Remove 
Point option is only available if all selected points are eligible for removal.

NOTE: This feature is not available from the Warping Tab.

1. Select the point that you want to remove.

2. From the Curve menu, click Remove Point.

Or:

3. Right-click on the point and select Remove Point.

6.4 Spring Mode 

SPRING mode (Figure 6-6) attempts to spread the effect of a point 
movement along its vertical and horizontal axes; therefore, moving one point 
automatically moves its neighbors to smooth out potential bunching. 

NOTE: Spring mode is available only for points on a warp grid. 

1. Ensure the Warping Tab is selected.

2. From the Curve menu, click Spring Mode.
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3. Select a point and drag to its new position. 

Figure 6-6 Spring Mode

6.5 Change Curve Tangent

You can change the shape of a curve without moving points by controlling 
the tangent of the control curve at each point. By default, the tangents of the 
curve at each point are calculated automatically by the software. The user 
may override this default value by manually specifying the tangent at one or 
more points on the control curve.

1. Select a point on the curve you want to adjust. 

2. To show the tangent controls, check Vertical Display/Horizontal 
Display from the Warping Tab.

3. Check the corresponding Manual option to unlock the tangent control.

4. Change the tangent of the curve by moving the tangent lines at the point, 
or by entering a tangent adjustment up to ±75°.

5. You can reset the guidelines of a view to their default shape at any time. 
Resetting a rotated projector view, removes the rotation from all views 
TWIST 1.6 User Manual 6-7
020-100143-07  Rev. 1 (06-2010)



Section 6: Working with the Main Interface
of the selected projector. From the Tools menu, click the option you 
want to reset. For example, Reset Warp, Reset Blend or Reset Mask.

Figure 6-7 Adjust curve tangent

6.6 Rotate the Warps, Blends and Masks

You can rotate the projected image up to ±5.0°. Rotation is applied to the 
selected projector and affects warps, blends and masks together. Portions of 
the rotated projection that fall outside of the default projection rectangle will 
not display on the screen. Resetting a rotated projector view, removes the 
rotation from all views of the selected projector.

NOTE: Rotation is not available when running the basic version of the 
TWIST Software.

1. Select a projector in the preview panel.

2. Click Edit>Rotate. When you rotate a projection, you clear all undos 
and redos for the selected projector. You will not be able to undo 
changes made prior to the rotation. 

Figure 6-8 Rotation Warning
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3. Specify a value in the Rotation Angle field and click OK.

Figure 6-9 Rotate 

6.7 Flip Warps, Blends, or Masks

You can flip a projection horizontally and/or vertically. For example, for a 
symmetrical 2 projector image you can set up one projector's warp, copy to 
the second projector, and flip it. Typically, the copied warp will need to be 
fine tuned, but the process can save time.

NOTE: Flipping is not available when running the basic version of the 
TWIST Software.

1. Select the projector you want to work with.

2. Click the Edit menu and select either Flip Horizontal or Flip Vertical. 

3. The appropriate flip dialog appears.

Figure 6-10 Select the View to Flip

4. Select the view(s) you want to flip (Warp, Blend, or Mask).

6.8 Undo and Re-Do Changes

Each tab tracks your actions for undo/redo. You can undo control point 
moves, tangent edits, addition and removal of points, and resets.

You cannot undo flipping, rotating, pasting, resetting, adding or deleting of 
projectors. Rotating a projector clears all undos up to the rotation for the 
selected projector. You will not be able to use CTRL+Z to undo any changes 
made to the projector prior to the rotation. 

• To undo a point adjustment, press CTRL+Z.

• To redo a point adjustment, press CTRL+Y.

• Use the Undo/Redo interface buttons .
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7 Warping

The following section provides an overview on warping and step-by-step 
instructions on how to control warps.

7.1 Overview

The number of input pixels drawn between neighboring control points is 
constant. By moving the control points, the number of output pixels used to 
represent these input pixels are increased or decreased. For example, a 5x5 
grid for a projector with a resolution of 1400x1050 pixels has 350 input 
pixels between horizontally adjacent points. By moving one point, you 
increase the number of output pixels in one neighboring block and decrease 
the other. The features under the Warping tab allow you to digitally adjust an 
image for projection on a non-standard surface. By default, the warping grid 
is set to 5x5 points.

7.2 Warping Tab Fields and Controls

Figure 7-1 Warping tab
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Projector – This is the name associated with the projector in the current 
configuration file. For information on how to change the name, see 4.3 Edit 
Projector Information.

Resolution – Indicates the number of control points in the warp matrix. For 
more information, see 4.3 Edit Projector Information.

Memory Location – Identifies the memory location on the projector 
where the warp will be saved. To change the memory location, see 4.3 Edit 
Projector Information.

Control Point Properties

Index – Identifies the grid co-ordinates of the select point. No index 
information is shown when multiple points are selected.

Point Label – Determines the type of label displayed at each point on the 
grid. Depending on the relative size in pixels of the grid and the projected 
images, moving the point one pixel on the computer screen may change the 
projector coordinates by multiple pixels.

Position – Identifies the point's absolute position in projector pixels. 

Offset – Identifies each point's displacement from its default location in 
projector pixels.

None – Hides the labels.

Position/Offset – Identifies the selected point's position or offset in 
projector pixels and allows you to precisely change the selected point's 
placement by entering the X and Y co-ordinates of the desired position or 
offset. Your selection in the Point Label field controls whether the 
coordinates entered are position or offset values.

Tangent – By default a point's tangents are calculated automatically based 
on the positions of its neighboring points along the horizontal and vertical 
axes. The tangent for a point that is at the edge of the grid is calculated using 
its neighbor and itself.

Display – The Horizontal and Vertical Display options allow you to 
show the tangent lines for the selected point(s). Check the options to 
show the tangent lines. 

Manual – The Manual option for Horizontal and Vertical tangents 
enables control of the tangent of the curve. Check this option to enable 
manual adjustment of the selected point's tangent. You can adjust the 
tangent by specifying a value in the Manual field, or by moving the 
tangent line. You can adjust a tangent up to ±75°.

Disable Gain Correction – On M-Series and StIM projectors, the 
warping algorithm automatically adjusts brightness uniformity based on the 
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calculation of the current warp. It analyzes compressions and expansions 
within the warp and adjusts brightness accordingly.

To disable this feature check the Disable Gain Correction option on the 
Warping Control Tab.

NOTE: This feature is only available on M-Series and StIM projectors. It is 
checked by default.

NOTE: The effect of the check box will only be seen once the warp's 
corresponding blend has been sent to the projector.

NOTE: When using this option with multiple warps and blends, warps and 
blends are linked to the same memory location index.

Save – Saves the current warp to the specified memory location on the projector. To 
save to a different memory location, click Edit>Properties and change the memory 
location before saving. To save the current warp to a configuration file, click 
File>Save. To save the current warp, blend, mask, and brightness uniformity to the 
selected projector, click Projector>Save All.

Preview – Previews the current warp on the specified projector without 
saving it. You can have the TWIST™ Software automatically preview each 
change to the projector as you make it. For more information, see 
5.7 Automatically Previewing Changes on the Projector. To preview the 
current warp, blend, mask and brightness uniformity to the selected 
projector, click Projector>Preview All.

7.3 Working with Warps

7.3.1 Select a Projector

1. To select a projector, zoom out of the preview until you can see the 
projector you want to work with.

2. Do one of the following:

• Using the Selection Tool  click to select the projector.
• Double-click to select the projector and automatically zoom and center 

to “best fit” the projector in the available workspace.

7.3.2 Change the Warping Grid Resolution

The warping grid is a wire frame representation of the projection. The grid 
resolution is specified in the configuration file.

When changing the resolution after the warp has been adjusted, the system 
recalculates the grid with minimal changes to the warp; however, this may 
have unexpected results.
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1. On the Edit menu, click Properties. The Properties dialog appears 
(Figure 7-2).

Figure 7-2 Changing the warp 
grid resolution

2. Adjust the Resolution. A higher number enables finer control of the 
warp map, but requires more adjustment.

3. Click OK to save the changes and close the dialog. The warp grid 
display is updated with the new calculations.
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7.3.3 Change the Warp Definition

The warping grid simulates the shape and distortions that will be applied to 
the projected image to warp it to fit the screen. 

1. To change a warp definition, select and move points to their desired 
locations. For more information about moving points, see 6 Working 
with the Main Interface. 

Figure 7-3 Warping a curved screen stretches the 
image to maintain perceived geometry of the Projection

2. Preview the warp to the projector. For details, see 5.6 Previewing Data 
on the Projector.

3. Save the settings to a configuration file. For details, see 4.5 Save Effects 
to a Configuration File.

4. Save the settings to a memory location on the projector. For details, see 
4.7 Save Effects to the Projector.

7.3.4 Test the Warp Against a Test Pattern

You can test the warp on the selected projector against a test pattern on the 
linked physical projector to see how well the warp adjusts the image to the 
screen. When the warp is optimized for the screen it will typically look 
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distorted on the computer, but the projected warp grid should look 
undistorted on the projection screen.

1. To project the current warp grid on the projection screen, click Test 
Pattern>Grid>Show Grid. 

2. Enable a test pattern on the projector by right-clicking on the projector 
to access the Context menu. Click Projector Control>Test Pattern 
and select the test pattern you want to work with. 

Figure 7-4 Test patterns

3. Use TWIST Test Pattern functions:

• To project the selected grid point, click Test Pattern>Show Selected 
Points. Moving a projected point automatically moves the point on 
the screen in real time. The warp is adjusted to match the new point 
location when you click the Send button on the Warping Tab.

• To make the grid easier to see, click Test Pattern>Grid Color or 
Test Pattern>Point Color and select the desired color.

• To check the grid against a black projection, click Test Pat-
tern>Show Black Test Pattern.

4. Make adjustment to the warp as required and click Preview to update 
the projection.
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7.3.5 Add a Warp

1. To add a warp to the selected projector, click Edit>Add Warp, Blend 
& Mask,

2. To confirm the warp was added check the project summary area of the 
interface. 

Figure 7-5 Projector Summary area - Multiple warps for Projector 2

7.3.6 Select a Warp to Work With

Multiple warps are included in a drop-down list in the Projector Summary 
area.

1. To see the list of available warps for the selected projector, click the 
drop-down arrow in the Memory Location column of the desired 
projector (Figure 7-5).

2. Select the desired memory location from the drop-down list.

7.3.7 Delete a Warp

You can delete the current warp. All but the last warp can be deleted from 
the configuration.

1. Select the projector from which you want to delete a warp.

2. Display the warp you want to delete. For more information, see 
7.3.6 Select a Warp to Work With.

3. Click Edit>Delete Warp, Blend & Mask or right-click and select 
Delete Warp, Blend & Mask.

NOTE: On M-series and StIM projectors, you can also delete the warp 
from memory on the projector. Click Yes at the prompt to delete the 
warp from memory on the projector.

4. To remove the warping information from the last warp, reset the warp 
by clicking Tools>Reset Warp.
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7.3.8 Copy a Warp to Another Projector

1. Display the warp you want to copy. For more information, see 
7.3.6 Select a Warp to Work With.

2. Click Edit>Copy Warp.

3. Select the projector you want to copy the warp to (target projector).

4. Ensure the warp displayed for the target projector is the one you want to 
replace, or create a new warp to be replaced. See 7.3.5 Add a Warp.

5. Click Edit>Paste Warp. The warp is saved over the current warp and 
the projector summary area shows the memory location of the replaced 
warp and the name of the copied warp. The name can be edited.

7.3.9 Save a Warp

For details, see 4.5 Save Effects to a Configuration File and 4.7 Save Effects 
to the Projector.

7.4 Warping on M-Series

7.4.1 Warp Continuity Mode

To compensate for possible warp scaling issues on M-Series and StIM 
projectors, Warp Continuity Mode performs additional validation when 
working with the warp grid. The effect is similar to that of spring mode. 
Moving points which create too large a distortion causes neighboring points 
to move to meet the requirements set by the hardware. 

By default Warp Continuity Mode is turned on for M-Series projectors. 

To disable Warp Continuity Mode

1. Right-Click the projector for which you want to disable the additional 
validation.

2. Click Properties.

3. On the Properties dialog, uncheck Warp Continuity Mode in the Warp 
group.

NOTE: Disabling this extra validation may cause unexpected results or 
visual artifacts when viewing the warp on the projector.

NOTE: This checkbox has no affect on non-M-Series projectors.

7.4.2 Disable Gain Correction

On M-Series and StIM projectors, the warping algorithm automatically 
adjusts brightness uniformity based on the calculation of the current warp. It 
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analyzes compressions and expansions within the warp and adjusts 
brightness accordingly.

This feature can be disabled by checking the Disable Gain Correction check 
box within the Warping Control Tab.

Figure 7-6 Disable Gain Correction

NOTE: This feature is only available on M-Series and StIM projectors. It is 
checked by default.

NOTE: The effect of the checkbox will only be seen once the warp's 
corresponding blend has been sent down to the projector.

NOTE: When using this option with multiple warps and blends, warps and 
blends are linked to the same memory location index.

7.5 TWIST TILING

Twist tiling control works with the tiling feature on M-Series and StIM 
projectors. It allows these projectors to be setup as a tiled array while 
providing warping, blending, masking and brightness uniformity control.

The image tiling feature allows a single input image to be spread over 
multiple screens, with each screen displaying a fraction or tile of the image 
(Figure 7-7). The image splitting is controlled through a distribution box, a 
signal switcher, or the loop-through functionality on the projector. The 
projector’s native tiling does not support warping and blending of tiled 
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projectors. TWIST tiling allows for overlapping and blending of tiled 
projectors.

Figure 7-7 Tiled 2×2 array

For information about setting up projectors in a tiled array, see the projector 
user manual.

7.5.1 TWIST Tiling Requirements

Tiling in Twist requires the following minimum projector firmware 
versions:

• M-Series projectors: Version 2.0

• StIM projectors: Version 1.3

7.5.2 Set Up TWIST Tiling

Tiling settings are associated and saved with the current warp, blend and 
mask.

Figure 7-8 Tiling manager

1. To access the Tiling Manager, click Tools > Tiling Manager.

2. To activate the tiling controls, check Tiling Enabled to enable tiling.
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3. Change the settings as required. See Tiling Manager on page 7-11.

4. Once you are satisfied with your setup, press OK to apply the settings 
and exit.

The effect will be seen once a warp is previewed or saved on the 
projector.

Tiling Manager 

Available Projectors  – Lists the available projectors. Use the arrow 
buttons to move selected projectors between the Available Projectors list 
and the Projectors To Tile table.

Projectors To Tile – Lists the projectors that are to be tiled. The values in 
the Row & Column cells indicate each projector’s position in the tiled array. 
Click the UP and DOWN buttons to rearrange the selected projector’s 
position in the tiled array.

Choose Layout – Select the tiled layout.

NOTE: Image artifacts may appear if a tiled array is greater than 3 high or 3 
wide.

Blend Calculation – Specify the overlap percentage between tiled 
projectors. If you have used the automatic blend calculation, these values 
should match the percentages used for the warping overlap, otherwise the 
tiles may not match.

7.5.3 View Calculated Tiling Settings 

The Tiling Control for <Warp name> dialog lets you view tiling parameters 
per-warp, per-projector. You can edit the values, but manual editing is not 
recommended if you have enabled and configured tiling via the Tiling 
Manager.

To access the dialog, right-click on a warp and select Tiling Control.

Figure 7-9  - Tiling Control

Tiling Enable – Indicates whether Tiling is enabled. 

Input Window – Indicates the pixel position of the upper left corner of the 
input window that the tiled warp will view.
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Input Window Size – Indicates the window size (pixels) of the input 
source the tiled warp will view. This window size is anchored at the pixel 
position specified by the Input Window X/Y values.

Note: The Input Window Size relates to the projector's native resolution (that 
is, after scaling has been done). It cannot be larger than the projector's native 
resolution.
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8 Blending

The following section provides an overview on blending and step-by-step 
instructions on working with and applying blends.

8.1 Overview

Blending is used to gradually reduce the brightness of the image from full 
brightness to black. This is used to enable multiple projectors to overlap their 
content without creating a bright band in the region where the projectors 
overlap.

Blending is composed of one or more edge blends each of which is composed 
of a white line, a black line, and a drop-off curve. The white line defines the 
point at which brightness begins to drop off. The black line defines the point 
at which the image is completely black. The drop-off curve defines the rate at 
which the brightness drops between the white and black lines.

For best results, adjust the warp before you attempt to blend any edges. If 
your warping results in an irregular edge, you can match your blending edge 
appropriately by using auto-blend or manually adjusting the blend curve. For 
more information, see 8.4.4 Shape a Blend to a Warped Projection.

When enabled, the black and white blend curves default to fit the current 
warp grid. The black curve will default to the edge of the projector; the white 
curve will default to a percentage inset from the edge of the projector. The 
default percentage value is 10%. If auto-blend is enabled, the percentage 
value used is user-defined.

Both the white and black curves can be adjusted to modify the size/shape of 
the blending region. Any information outside of the black curve will not be 
projected.

Twist PRO enables the Spherical Blending feature in Twist. Rather than 
edge-based blends, spherical blending is defined by the same IG channel 
extents used to do geometric correction of spherical (frustum-corrected) 
data. Thus, this feature can be used when projector geometry/warping is 
TWIST 1.6 User Manual 8-1
020-100143-07  Rev. 1 (06-2010)



Section 8: Blending
defined by spherical channel extents (i.e. in a training simulator on a curved 
screen). See section 8.5 Spherical Blending for more details.

8.2 Automatic Blend Calculation

Automatic blending is calculated based on visible projected image area. The 
default box that represents a projector in the Twist™ window is the full 
potential projection. Typically, your warped projection will lie within its 
boundaries. In this case, the blend is calculated based on the warped image 
area.

Figure 8-1 15% blend based on width of warped image
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If warping the image to fit the screen results in parts of the image being 
stretched beyond the visible projected area, only the projected area is used to 
calculate the blend area. Image fragments outside the visible projection area 
are ignored. By default, masked fragments are also ignored when calculating 
blend widths automatically.

Figure 8-2 15% blend based on Projection area

By default, a change in the mask causes a change in the automatic blend 
calculation across the entire blend region. This is desirable when warping a 
dome; however, in simple applications where you legitimately need to mask 
a small part of the screen to deal with some projection issues, this effect on 
the entire blend can be unexpected and unwanted. If masking unexpectedly 
alters the automatic blend calculation, you can optionally exclude masking 
from your automatic blend calculation and base the calculation on the 
warped image in the visible projection area. Of course, you can also adjust 
calculated blends manually to match irregularly shaped screens more 
completely.

For information about working with points, see 6 Working with the Main 
Interface.

8.3 Blending Tab Fields and Controls

Projector – This is the name associated with the selected projector in the 
current configuration file. To change the name, see 4.3 Edit Projector 
Information.

Memory Location – Identifies the memory location on the projector 
where the blend will be saved. To change the memory location, see 4.3 Edit 
Projector Information.
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Edge Blending/Spherical Blending – Controls which functions display 
on the Blending tab. These option buttons and the spherical blending 
functions (8.3.1 Edge Blending Settings) are supported in the TWIST Pro 
software only. The basic version of the software always displays the edge 
blending functions (8.4 Working with Blends).

8.3.1 Edge Blending Settings

Figure 8-3 Blending Tab - Edge Blending, TWIST and TWIST Pro

Active Edges

Allows you to specify which edge(s) of the projection will be blended. 
Check an edge to activate it and to show its blending guidelines. The TWIST 
Software can be setup to automatically calculate the edge of a blend to match 
an irregular projection. For more information, see 8.4.4 Shape a Blend to a 
Warped Projection.

Control Point Properties

Point Label – Determines the type of label displayed at each point of the 
blending guidelines. Depending on the relative size in pixels of the grid and 
the projected images, moving the point one pixel on the screen may change 
the coordinates by multiple pixels.

• Position: Identifies the point's co-ordinates in projector pixels. 
• None: Hides the labels.

Position (X,Y) – Identifies the position of the selected point in projector 
pixels and allows you to precisely change the placement of the selected point 
by entering the X and Y co-ordinates of the desired position.
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Tangent – By default a point's Horizontal or Vertical tangent is calculated 
automatically based on the positions of its neighboring points along the 
horizontal and vertical axes. The tangent for a point that is at the edge of the 
grid is calculated using its neighbor and itself. You can change the tangent 
manually. 

Display – The Display option allows the user to show the vertical or 
horizontal tangent lines for the selected point(s). Check the option to 
show the tangent lines. 

Manual – The Manual option for horizontal and vertical tangents enables 
control of the tangents curve. Check these options to enable manual 
adjustment of the selected point's tangent. You can adjust the tangent by 
specifying a value in the Manual field, or by moving the tangent line. 
You can adjust a tangent up to ±75°.

Drop Off Curve

Figure 8-4 Drop-Off Curve Control

Controls the gradation of luminosity in the blend area described by the blend 
guidelines. Click on the point in the Drop Off Curve and move it to change 
the gradation. You can add more points to the drop off curve as required 
(Figure 8-4).

Expand/Collapse Button – The expand button  opens the Drop 
Off Curve dialog which has a larger version of the drop off curve control. 

The collapse button  minimizes the Drop Off Curve dialog. Changes 
the dialog are displayed in the Drop Off Curve control on the Blend Tab.

Reset Button – The Reset button sets the tangent curve back to the default 
straight line.

Drop Off Curve Tangent – By default a point's tangent is calculated 
automatically based on the positions of its neighboring points along the 
horizontal and vertical axes. The tangent for a point that is at the edge of the 
grid is calculated using its neighbor and itself. You can change the tangent 
by entering a value in the Tangent/Manual field. 

Save – Saves the current blend to the specified memory location on the 
projector. To save to a different memory location, click Edit>Properties, 
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and change the memory location before save. To save this blend in the 
configuration file, click File>Save.

Preview – Previews the current blend on the specified projector without 
saving it. The TWIST Software can be setup to automatically preview each 
change to the projector as you make it. For more information, see 
5.7 Automatically Previewing Changes on the Projector.

8.4 Working with Blends

8.4.1 Enable Automatic Blend Calculation

For an existing configuration, you can enable automatic blend calculation for 
the selected projector. Automatic blending can be enabled for all the 
projectors when you create a new configuration file.

1. In the Blending Tab, enable the active edge(s) that will be blended (i.e., 
Top, Bottom, Left, Right).

2. Click Tools>Automatic Blend Calculation.

3. The Automatic Blend Calculation dialog box opens with the active 
edges checked for automatic calculation.

Figure 8-5 Automatic Blend Calculation

4. Click OK.

5. If masking one side of your image results in an unworkable blend, you 
can exclude masking from your automatic blend calculation by 
disabling the Use masking when calculating automatic blend option. 
You can disable automatic blend calculation on the selected projector 
using the same dialog.
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8.4.2 Change the Blend Definition

Blend guidelines simulate the shape of the blending region.

1. You can shape the blend to a warp definition to get a starting point for 
shaping the blend. For more information, see 8.4.4 Shape a Blend to a 
Warped Projection.

2. To refine the shape of the blend definition select and move points to 
their desired locations. For more information about moving points, see 
6 Working with the Main Interface. 

Figure 8-6 Generated blend shaped for a curved screen

3. Change the shading of the blend. For details, see 8.4.5 Change the 
Shading of the Blend.

4. Automatically send the changes to the projector. For details, see 
5.7 Automatically Previewing Changes on the Projector.

5. Save the settings to a configuration file. For details, see 4.5 Save Effects 
to a Configuration File.

6. Save the settings to a memory location on the projector. For details, see 
4.7 Save Effects to the Projector.
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Section 8: Blending
8.4.3 Advanced Point Placement

Advanced point placement is a useful tool when projecting onto advanced 
systems, such as domes. It enables a user to drag points outside of the 
projected area. The TWIST Software recalculates the blended area within 
that specified region.

NOTE: Advanced point placement is not available when running the basic 
version of the TWIST Software.

1. From the Tools menu, click Advanced Point Placement (Figure 8-7).

2. Click on a specific point and drag it to the desired position. 
Alternatively, you can specify coordinates in pixels for the selected 
point through the Position XY fields on the Blending Tab. The only 
limitations with this feature is end points on the top curve cannot be 
moved off the left and right edge of the grid, and black and white curves 
cannot be crossed.

Figure 8-7 Advanced Point Placement

8.4.4 Shape a Blend to a Warped Projection

Generally, warp changes are completed before attempting to blend projector 
images so that the warping information can be used to guide the blend.

1. Click on the Blending Tab.
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2. To automatically shape the blend to your warp, click Tools>Automatic 
Blend Calculation. The Automatic Blend Calculation dialog box 
appears.

Figure 8-8 Blend calculation

3. Check the edges that will be blended (i.e., Top Overlap, Bottom 
Overlap, Left Overlap, Right Overlap) and specify the width of the 
blend. For example, specifying a blend width of 10% represents a 
percentage of the total resolution of the input image. If the input image 
has a resolution of 1400 x 1050 pixels, a 10% right overlap indicates the 
right 140 pixels of the input image will be in the blend. The blend 
regions will be automatically calculated and shaped to the warp. 

4. You can adjust the fit of the blend's curve by moving the curve or 
individual points until you have the desired blending region. For more 
information, see 6 Working with the Main Interface. 

8.4.5 Change the Shading of the Blend

The shading of the blend area is controlled by the Drop Off Curve, which 
describes how the luminosity at the blending edge of the image is changed. 
Each blending edge has its own drop-off curve. The blend area of two 
complimentary profiles or four complimentary profiles should produce an 
even luminosity that matches the unblended areas of the image.

Figure 8-9 Various blend curves
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Section 8: Blending
The blending guidelines on the computer show only the shape of the curve. 
The Drop Off Curve preview (Figure 8-4) shows only the gradation, not 
the orientation of the blending edge. The white side of the preview 
corresponds to the white guideline. And the dark side of the preview 
corresponds to the black line. The projector image shows the degree of 
success of the blend.

To change the drop-off curve: 

• Move a point toward the upper-left for more white and a sharper drop 
off.

• Move a point towards the lower-right for more dark and a sharper drop 
off.

• Adjust the tangent of the curve. 

• Add a point to the curve for more control.

To work with a larger version of the Drop Off Curve control click the 

Expand button .

8.4.6 Advanced Edge Blending

By default the drop-off for an edge blend will run purely horizontally for left 
and right blends, and vertically for top and bottom blends. In advanced 
visual systems, where projectors do not necessarily line up in a regular 
matrix, it is sometimes necessary for blends to drop-off along different 
direction vectors to adjust to irregular overlap regions between projectors. 
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Add Directional Vector

1. Right-click on a line and select Add Directional Vector from the menu 
selections that appear.

Figure 8-10 Add Directional Vector

2. Select a point on the white curve and a point on the black curve.

3. Users can define up to 10 vectors for any given curve. The system 
interpolates between adjacent drop-off vectors to determine intermedi-
ate drop-off directions.

4. Each drop-off vector has an associated drop-off curve, which 
determines how the brightness will drop from bright to dark, between 
the white and black lines of the edge blend.

Remove Directional Vector

Right-click on the directional vector and select Remove Directional Vector 
from the menu selections that appear.

Work with Directional Vectors

When adding a directional vector ensure the points specified from the black 
curve to the white curve don’t intersect with the white curve. Figure 8-11 
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Section 8: Blending
illustrates a bad line placement. Here the directional vector crosses the white 
curve, which will result in a bad blend. 

Figure 8-11 Bad Vector PLacement

To ensure this problem does not occur add additional directional vectors 
where needed, or change the curve’s position. Figure 8-12 illustrates an 
accurately placed directional vector.

Figure 8-12 Proper Vector PLacement
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8.4.7 Edge Blend Masking

This Pro feature is different from masking in that it masks areas of the blend 
instead of masking parts of the image itself. It is helpful to use when two 
projected images are overlapping and you want to blend the area of the 
overlap. Blend masking will allow you to mask only the overlapped area 
without affecting the rest of the projected image.

1. From the Tools menu, click Blend Masking.

2. Two lines appear on the selected projector grid. Click and drag the lines 
to specify the area of the blend to mask. 

Figure 8-13 Edge Blend Masking of Two Overlapping Projected Images
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Section 8: Blending
8.4.8 Add a Blend

To add a blend to the selected projector, click Edit>Add Warp, Blend, & 
Mask.

To check that a blend has been added to the projector in the projector 
summary area, click the drop-down arrow in the Memory Location column. 

Figure 8-14 Projector Summary - Blend Memory Location

8.4.9 Select a Blend To Work With

Multiple blends are included in a drop-down list in the projector summary 
area.

1. To see the list of available blends for the selected projector, click the 
drop-down arrow in the Memory Location column for the desired 
projector (Figure 8-14).

2. Select the desired memory location from the drop-down list.
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8.4.10 Delete a Blend 

You can delete the current blend. All but the last blend can be deleted from 
the configuration. 

1. Select the projector from which you want to delete a blend.

2. Display the blend you want to delete. For more information, see 
8.4.9 Select a Blend To Work With.

3. Click Edit>Delete Warp, Blend & Mask or right-click and select 
Delete Warp, Blend & Mask.

NOTE: On M-series and StIM projectors, you can also delete the blend from 
memory on the projector. Click Yes at the prompt, to delete the blend from 
projector memory.

NOTE: To remove the blending information from the last blend, reset the 
blend by clicking Tools>Reset Blend.

8.4.11 Copy a Blend to Another Projector

When pasting, a blend replaces the current blend on the target projector. 

1. Display the blend you want to copy. For more information, see 
8.4.9 Select a Blend To Work With.

2. Click Edit>Copy Blend.

3. Select the projector to copy the blend to (target projector).

4. Ensure the blend displayed for the target projector is the one you want to 
replace, or create a new blend to be replaced. For details, see 8.4.8 Add 
a Blend.

5. Click Edit>Paste Blend. The blend is saved over the current blend and 
the projector summary shows the memory location of the replaced blend 
and the name of the copied blend. The name can be edited.

8.4.12 Save a Blend

For information, see 4.5 Save Effects to a Configuration File and 4.7 Save 
Effects to the Projector.

8.5 Spherical Blending

NOTE: Spherical Blending is available in TWIST Pro software only.

The Spherical Blending feature is used to calculate precise blends when 
projector geometry/warping is defined by spherical channel extents for 
frustum-corrected data, for example in a training simulator on a curved 
screen.
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By defining the channel extents for each projector, Twist is able to determine 
the overlap of each projector in 3D space and is therefore able to construct a 
specific blend for each projector as it relates to neighboring projectors.

Spherical data is projected from an eye point, along a Heading (direction 
vector), with a window size defined by the horizontal and vertical Field of 
View values. Figure 8-16 and Figure 8-17 illustrate how spherical channel 
extents are defined.

8.5.1 Spherical Blending Settings

Spherical blend controls are enabled by clicking the Spherical Blending 
option on the Blending tab.

Figure 8-15 Spherical Blending, TWIST Pro

Heading (Degrees) – Identifies the heading in terms of yaw, pitch, and 
roll values in degrees (Figure 8-16).

Figure 8-16 Spherical Co-ordinates
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Field of View (Degrees) – Identifies the field of view as boundaries, 
specified in degrees difference from the heading. 

Figure 8-17 Defining Spherical Channel Extents

Edit Spherical Blend – Opens the Spherical Blend dialog where you can 
quickly edit headings and fields of view for multiple projectors.

Figure 8-18 Edit Spherical Blend
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8.5.2 Working With Spherical Blends

1. To enable Spherical Blending control, on the Blending tab choose the 
Spherical Blending option.

Figure 8-19 Choose Spherical Blending

2. On the Blending tab of the control panel, enter the channel extent data 
for each projector.

If Show Gradient Image is enabled (see Figure 6-1), changing channel 
extent data on the Blending control panel automatically updates the 
blend viewer to display the correct gradient/blend image. 

NOTE: When changing channel extent data on the Edit Spherical Blend 
dialog, the blend viewer updates when OK is pressed on the dialog.

3. Automatically send the changes to the projector. For details, see 
5.7 Automatically Previewing Changes on the Projector.

4. Save the settings to a configuration file. For details, see 4.5 Save Effects 
to a Configuration File.

5. Save the settings to a memory location on the projector. For details, see 
4.7 Save Effects to the Projector.
8-18 TWIST 1.6 User Manual
020-100143-07  Rev. 1 (06-2010)



9 Masking

The following section outlines how to work with masks.

9.1 Overview

Sometimes fitting the image to a specified screen shape without distorting 
the geometry of the image affects the shape of the image. You can mask the 
extraneous information at the edge of the image. The default box on the 
Masking Tab's work area is the full potential projection, not the warped 
projection. Typically, the warped projection will lie within the boundaries of 
the default projection. 

9.1.1 Masking Tab

Figure 9-1 Masking Tab

Projector – This is the name associated with the selected projector in the 
current configuration file. To change the name, see 4.3 Edit Projector 
Information.

Memory Location – Identifies the memory location on the projector 
where the masking definition will be saved. 

Active Edges – Allows you to specify which edge(s) of the projection will 
be masked. Check an edge to activate it and show its masking guideline. 
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Point Label – Determines the type of label displayed at each point on the 
masking guidelines. 

• Position: Identifies the point's co-ordinates in projector pixels. 

• Offset: Identifies the change in each point's position in projector pixel.

• None: Hides the point labels.

NOTE: Depending on the relative size in pixels of the grid and the projected 
images, moving the point one pixel on the screen may change the 
coordinates by multiple pixels.

Position/Offset XY – Identifies the selected point's position or offset in 
projector pixels and allows you to precisely change the selected point's 
placement by entering the X and Y co-ordinates of the desired position or 
offset. Your selection in the Point Label field controls whether the 
coordinates are position or offset.

Tangent – By default a point's vertical or horizontal tangent is calculated 
automatically based on the positions of its neighboring points along the 
horizontal and vertical axes. The tangent for a point that is at the edge of the 
grid is calculated using its neighbor and itself. You can change the tangent 
manually.

• Display: The Display option allows you to show the tangent lines for 
the selected point(s). 

• Manual: The Manual option for horizontal and vertical tangents 
enables control of the tangent of the curve. Check this option to enable 
manual adjustment of the selected point's tangent. You can adjust the 
tangent by specifying a value in the Manual field, or by moving the 
tangent line. You can adjust a tangent up to ± 75°.

Save – Saves the current blend to the specified memory location on the 
projector. To save to a different memory location, click Edit>Properties and 
change the memory location before you click Save. Such a change will 
affect the warp definition as well. To save this mask definition in the 
configuration file, click File>Save.

Preview – Previews the current mask on the specified projector without 
saving it. The TWIST™ Software can be setup to automatically preview 
each change to the projector as it is made. For more information, see 5.7 
Automatically Previewing Changes on the Projector.
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9.2 Working with Masks

9.2.1 Change the Mask Definition

The masking guidelines simulate the shape that will be applied to the 
projected image to prevent data from being projected beyond the desired 
boundary.

1. To change a mask definition select and move guideline points to their 
desired locations. For more information about moving points, see 6 
Working with the Main Interface.

2. Send the mask to the projector. For more information, see 5.6 
Previewing Data on the Projector.

3. Save the settings to a configuration file. For details, see 4.5 Save Effects 
to a Configuration File.

4. Save the settings to a memory location on the projector. For details, see 
4.7 Save Effects to the Projector.

Figure 9-2 Mask Trimming Bottom of Projection
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10 Brightness Uniformity

NOTE: Brightness Uniformity is available in TWIST™ Pro Software only.

10.1 Overview

This feature enables a user to manipulate brightness uniformity in instances 
where projectors are placed in positions where the direction of projection 
differs greatly from the normal surface of the screen. In these type of 
installations it results in image keystoning and brightness uniformity 
differences across the image, and in some instances inconsistencies in the 
native size of the adjacent channels. To compensate for these inconsistencies 
the brightness uniformity feature can be used to define a regular array of 
control points at which the brightness value can be specified. Both edge 
blending and brightness uniformity are usable on the same display through 
independent user controls. Both effects are combined and sent to the board 
as a single gain matrix. 

10.2 Brightness Uniformity Tab Fields and Controls

Figure 10-1 Brightness Uniformity

Projector – This is the name associated with the selected projector in the 
current configuration file. To change the name, see 4.3 Edit Projector 
Information.
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Global Intensity – This is the gain value associated with the selected 
projector. For details, see 4.3.1 Properties Dialog/Add a New Projector.

Brightness Uniformity Information

Name – Displays the name of the selected brightness uniformity.

Warp – Select the specific warp to apply to the active projector from this 
drop-down menu.

Grid Properties

Grid Size – Specifies the grid resolution of the brightness uniformity.

Point Label – Determines the type of label displayed at each point on the 
control points.

• Value: Identifies the points gain value.

• None: Hides the points gain value.

Grid Values

Point – When a point is selected these fields display the XY coordinates of 
the point. The fields are grayed out when no point is selected or if multiple 
points are selected.

Gain Value – When a point is selected this field displays the gain value of 
the point. If two or more points are selected with different gain values the 
field remains grayed out.

Save – Saves the current brightness uniformity to the specified memory 
location on the projector. To save to a different memory location, click 
Edit>Properties and change the memory location before you click Save. To 
save this brightness uniformity definition in the configuration file, click 
File>Save.

Preview – Displays the current brightness uniformity on the specified 
projector without saving it. The TWIST Software can be setup to 
automatically preview each change to the projector as it is made. For more 
information, see 5.7 Automatically Previewing Changes on the Projector.
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10.2.1 Add Brightness Uniformity

To add brightness uniformity to the selected projector, click Edit>Add 
Warp, Blend, Mask & Brightness Uniformity.

You can check that brightness uniformity has been added to the projector in 
the projector summary area, by selecting the drop-down arrow in the 
Memory Location column for the specific projector. 

Figure 10-2 Add Brightness Uniformity

10.2.2 Select a Brightness Uniformity To Work With

Multiple brightness uniformities are included in a drop-down list in the 
Projector Summary area.

1. To see the list of available brightness uniformities for the selected 
projector, click the drop-down arrow in the Memory Location column 
for the desired projector (Figure 10-3).

2. Select the desired memory location from the drop-down list.

Figure 10-3 Projector Summary - Brightness Uniformity
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10.2.3 Working with Brightness Uniformity

1. Specify a control point matrix for controlling brightness values in the 
Grid Size XY fields on the Brightness Uniformity Tab. Choose from a 
2x2 up to an 11x11 matrix of points. 

Figure 10-4 Brightness Uniformity, Gain=0

Figure 10-5 Brightness Uniformity, Gain=1
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2. Using the mouse or keyboard select the control point(s) on the canvas. 

NOTES: 1) Control points cannot be moved from their original points. 2) 
The number of control points can be changed interactively during 
calibration. 3) When changing control points the gain across the image 
is not necessarily maintained.

3. Specify a single gain value for the currently selected control point(s) in 
the Gain Value field. The brightness value at each of the points can 
range from fully black (0.0) to unmodified (1.0). Depending on the gain 
value specified the control point will turn white to indicate full 
brightness or black for full darkness (Figure 10-6).

NOTE: Intermediate gain values for the hardware are calculated using 
bicubic interpolation between the user specified control points.

4. Click on the Show Gradient Image button  to display the 
uniformity being worked on.

5. Once all selected control points have identical gain values the entry field 
in the control panel will display the value for editing. When the gain 
values are not identical this field remains blank, but can still be used to 
apply a common gain value to the selected points.

10.2.4 Saving Brightness Uniformity

For information, see 4.5 Save Effects to a Configuration File and 4.7 Save 
Effects to the Projector.

10.2.5 Deleting Brightness Uniformity

You can delete the current brightness uniformity. All but the last brightness 
uniformity can be deleted from the configuration. When you delete a 
brightness uniformity, the associated blend is deleted also.

1. Select the projector from which you want to delete brightness 
uniformity.

2. Display the brightness uniformity you want to delete. For more 
information, see 10.2.2 Select a Brightness Uniformity To Work With.

3. Click Edit>Delete Warp, Blend, Mask & Brightness Uniformity or 
right-click and select Delete Warp, Blend, Mask & Brightness 
Uniformity.

To remove the brightness uniformity information from the last blend, reset 
the uniformity by clicking Tools>Reset Brightness Uniformity.
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10.2.6 Copy Brightness Uniformity to Another Projector

When pasting, brightness uniformity replaces the current brightness 
uniformity on the target projector. 

1. Display the brightness uniformity you want to copy. For more 
information, see 10.2.2 Select a Brightness Uniformity To Work With.

2. Click Edit>Copy Brightness Uniformity.

3. Select the target projector to copy the brightness uniformity to.

4. Ensure the brightness uniformity displayed for the target projector is the 
one you want to replace, or create a new brightness uniformity to be 
replaced. For details, see 10.2.1 Add Brightness Uniformity.

5. Click Edit>Paste Brightness Uniformity. The brightness uniformity is 
saved over the current brightness uniformity and the project summary 
shows the memory location of the replaced brightness uniformity and 
the name of the copied uniformity. The name can be edited.

10.2.7 Gradient Image

Use this feature to view the drop off from edge blends and brightness 
uniformity in the workspace. This feature is useful when working with 
advanced blending and brightness uniformity. From the Brightness 
Uniformity Tab the brightness uniformity being worked on is displayed 
(Figure 10-6). From all other tabs a combination of the brightness 
uniformity matrix, edge blends and global intensity is displayed. To view the 

gradient click on the Show Gradient Image button .

Figure 10-6 Show Gradient Feature
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11 Troubleshooting

11.1 Location of Log Files

Twist generates log files which may be useful when troubleshooting issues. 
These files are located in the following location:

• Windows 7:
%SystemDrive%\ProgramData\Christie Digital Systems\Twist\logs
(for example C:\ProgramData\Christie Digital Systems\Twist\logs)

• Windows XP:
%ALLUSERSPROFILE%\Application Data\Christie Digital 
Systems\Twist\logs
(for example. C:\Documents and Settings\All Users\Application 
Data\Christie Digital Systems\Twist\logs)

This directory contains the file logging.properties, which can be modified to 
fine-tune the logging that Twist does.
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APPENDIX A Fine Tuning Warps

A.1 Projector Control

Access the projector menu via the control buttons on the projector, or via the 
remote control. The menus display on the projected screen. All menu options 
are numbered. You can select menu items either by selecting the option 
using the up and down arrow buttons and then pressing Enter, or by pressing 
the option number on the number pad.

A.2 Disable Effects

If a warp, blend, or mask makes it difficult to read the menus or source on 
the projected screen, you can temporarily disable effects from within the 
TWIST™ Software.

• To temporarily disable warping and masking, click the projector menu 
and check the Disable Warp option. 

• To temporarily disable blending, click the projector menu and check the 
Disable Blend option.

• To temporarily disable brightness uniformity, click the projector menu 
and check the Disable Brightness Uniformity option.

NOTES: 1) Uncheck a disabled option to enable it. 2) Enabling an option 
causes the projector to apply the last saved definition(s) at the memory 
location(s) specified in the current configuration file.
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A.3 Fine Tuning on Non-M-Series and non-StIM Projectors

This section does not apply to M-Series or StIM projectors. To fine tune 
these projectors, see A.4 Fine Tuning on M-Series and StIM Projectors.

A.3.1 Select a Warp

1. Press the Menu button to access the main menu.

Figure A-1 Projector control panel

2. Select 4 Configuration.

3. Select 8 Geometry and Color.

4. Select 2 Keystone and Warping.

5. Select 1 Warp Select to display the list of warps.

6. Select the warp to display. The warp is applied automatically. If the 
warping introduces aliasing, you can use the warp pre-filters and warp 
sharpness to minimize the problem. 

7. Press the Menu button to exit the projector's menu structure.

A.3.2 Adjusting Warp Pre-Filters and Warp Sharpness

Sometimes warping can introduce aliasing, which can be minimized in the 
following way:

1. Press the Menu button. 

2. Select 4 Configuration.

3. Select 8 Geometry and Color.

4. Select 2 Keystone and Warping.

5. Select (using the Up and Down buttons) and adjust (using the Left and 
Right buttons) the following as needed:

• Warp Pre-filter Horizontal: Increase this value to blur the image 
and lessen horizontal aliasing. 

• Warp Pre-filter Vertical: Increase this value to blur the image and 
lessen vertical aliasing. 

• Warp Sharpness: Increase this value to re-sharpen the image after 
using vertical and horizontal pre-filtering. This re-introduces a finer 
grained aliasing. 
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NOTE: Changes to these settings are interactive.

6. Press the Menu button to exit the projector's menu structure.

A.3.3 Select a Blend

1. Press the Menu button.

2. Select 4 Configuration.

3. Select 8 Geometry and Color.

4. Select Edge Blending.

5. Select 1 Blending Select and press Enter to display the list of blends.

6. Select the blend to apply.

7. Press the Menu button to exit the projector's menu structure.

A.4 Fine Tuning on M-Series and StIM Projectors

This section applies only to M-Series and StIM projectors. To fine tune other 
Christie Projectors, see A.3 Fine Tuning on Non-M-Series and non-StIM 
Projectors.

A.4.1 Select a Warp on M-Series or StIM Projectors

1. Press the Menu button to access the main menu.

2. Select 4 Configuration.

3. Select 8 Geometry and Color.

4. Select 2 Geometry Correction.

5. Select 1 Geometry Correction to display the list of warps.

6. Select the warp to display. The warp is applied automatically.

7. Press the Menu button to exit the projector's menu structure.

A.4.2 Select A Blend On M-Series or StIM Projectors

1. Press the Menu button to access the main menu.

2. Select 4 Configuration.

3. Select 8 Geometry and Color.

4. Select 4 Edge Blending.

5. Select 1 Edge Blending to display the list of blends.

6. Select the blend to display. 

7. Press the Menu button to exit the projector's menu structure.
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selecting projectors 5-1, 5-2
send, see projectors preview
serial connection 4-1
set up

projectors 2-3, 2-4
TWIST tiling 7-10

shortcut keys 6-1
spherical blending 8-15

field of view 8-17
heading 8-16

spring mode 6-6
starting TWIST 2-5

T
tiling 7-9

requirements 7-9
setup 7-10
tiling control dialog 7-11
tiling manager dialog 7-10

U
undo 6-9
USB license key 2-4

V
view tiling settings 7-11
virtual remote 3-4, 5-4

W
warp continuity 4-7
warping 7-1

changing 7-5
control points 7-2
gain correction 7-2, 7-8
grid resolution 7-3
memory location 4-4
name prefix 4-4
overriding 5-3
resolution 4-4
save 7-8
tangent 7-2

warps
adding 7-7
continuity mode 7-8
copying to another projector 7-8
definition 7-5
deleting 7-7
grid resolution 7-3
selecting 7-7
testing 7-5

Z
zooming 5-1
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